summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--pass/PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/pass/PKGBUILD b/pass/PKGBUILD
new file mode 100644
index 0000000..3209e41
--- /dev/null
+++ b/pass/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Justin Gassner <justin.gassner@web.de>
+
+_pkgname=pass
+pkgname=$_pkgname-jxir
+pkgver=1.7.1.10.ga61c527
+pkgrel=1
+pkgdesc='Stores, retrieves, generates, and synchronizes passwords securely'
+arch=('any')
+url='https://zx2c4.com/projects/password-store/'
+license=('GPL2')
+depends=('bash' 'gnupg' 'pwgen' 'xclip')
+optdepends=('git: for Git support'
+ 'dmenu: for passmenu')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+https://git.jxir.de/$_pkgname")
+sha256sums=('SKIP')
+
+pkgver(){
+ cd "$_pkgname"
+ git describe --tags | sed 's/-/./g'
+}
+
+prepare() {
+ cd "$_pkgname"
+ for branch in no-tree; do
+ git merge --no-edit origin/$branch
+ done
+}
+
+package() {
+ cd "$_pkgname"
+ make DESTDIR="$pkgdir" FORCE_ALL=1 install
+ install -Dm0755 contrib/dmenu/passmenu "$pkgdir/usr/bin/passmenu"
+}