aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJay Berkenbilt <jberkenbilt@users.noreply.github.com>2023-06-17 20:02:44 +0200
committerGitHub <noreply@github.com>2023-06-17 20:02:44 +0200
commit463953bc96ead56227ef3dbf62639eb7e3545ab4 (patch)
tree357065933d636effd8a2651571eb2c02e22a847c /CMakeLists.txt
parent9b09436ce1f7427570f1016d02e7bf2bed4479f4 (diff)
parent13761120b1dbe126a9d39b9439086b76b4860b27 (diff)
downloadqpdf-463953bc96ead56227ef3dbf62639eb7e3545ab4.tar.zst
Merge pull request #992 from jberkenbilt/future
Future
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d2ec8ffd..ac0c0435 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -104,6 +104,8 @@ option(INSTALL_PKGCONFIG "Install pkgconfig file" ON)
option(INSTALL_CMAKE_PACKAGE "Install cmake package files" ON)
option(INSTALL_EXAMPLES "Install example files" ON)
+option(FUTURE "Include ABI-breaking changes CONSIDERED for the next major release" OFF)
+
# *** END OPTIONS ***
if(NOT (BUILD_STATIC_LIBS OR BUILD_SHARED_LIBS))
@@ -121,6 +123,10 @@ else()
set(ENABLE_QTC_ARG --disable-tc)
endif()
+if(FUTURE)
+ add_compile_definitions(QPDF_FUTURE=1)
+endif()
+
enable_testing()
set(RUN_QTEST perl ${qpdf_SOURCE_DIR}/run-qtest ${ENABLE_QTC_ARG})
@@ -347,6 +353,7 @@ message(STATUS " build static libraries: ${BUILD_STATIC_LIBS}")
message(STATUS " build manual: ${BUILD_DOC}")
message(STATUS " compiler warnings are errors: ${WERROR}")
message(STATUS " QTC test coverage: ${ENABLE_QTC}")
+message(STATUS " include future changes: ${FUTURE}")
message(STATUS " system: ${CPACK_SYSTEM_NAME}")
message(STATUS "")
message(STATUS "*** Options Summary ***")