aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJay Berkenbilt <ejb@ql.org>2022-10-06 12:58:25 +0200
committerJay Berkenbilt <ejb@ql.org>2022-10-06 12:58:38 +0200
commit6826330adc9dfe3f8ac6c0d911991d4591653151 (patch)
tree08e3e03c4555c0e759f186075a3d3f13c5e3212e /CMakeLists.txt
parent741211a199923310dad880ea1dc903ca2476ad48 (diff)
downloadqpdf-6826330adc9dfe3f8ac6c0d911991d4591653151.tar.zst
Require a C++-17 compiler
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5c0915f3..bb90b468 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -153,7 +153,7 @@ Please build with cmake in a subdirectory, e.g.
Please remove CMakeCache.txt and the CMakeFiles directories.")
endif()
-set(CMAKE_CXX_STANDARD 14)
+set(CMAKE_CXX_STANDARD 17)
set(CMAKE_CXX_EXTENSIONS OFF)
set(CMAKE_CXX_STANDARD_REQUIRED ON)
set(CMAKE_C_VISIBILITY_PRESET hidden)