aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJay Berkenbilt <ejb@ql.org>2019-06-21 03:08:04 +0200
committerJay Berkenbilt <ejb@ql.org>2019-06-21 19:17:21 +0200
commitcc2e8853b5a87eefa304c03d2d242a339d942c77 (patch)
tree2636b3649d2571a9eaec4b3ec13ce61ea57bb764 /configure.ac
parent63a643a3c750c2cb6e667d5bbfc443080140832c (diff)
downloadqpdf-cc2e8853b5a87eefa304c03d2d242a339d942c77.tar.zst
Enable int warnings by default
Now that there aren't any more...
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 9dba223f..33ec733f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -396,12 +396,12 @@ fi
AC_MSG_CHECKING(for whether to use $try_flags)
AC_ARG_ENABLE(int-warnings,
AS_HELP_STRING([--enable-int-warnings],
- [whether to turn on integer type warnings (default is no)]),
+ [whether to turn on integer type warnings (default is yes)]),
[if test "$enableval" = "yes"; then
qpdf_INT_WARNINGS=1;
else
qpdf_INT_WARNINGS=0;
- fi], [qpdf_INT_WARNINGS=0])
+ fi], [qpdf_INT_WARNINGS=1])
if test "$qpdf_INT_WARNINGS" = "1"; then
AC_MSG_RESULT(yes)
WFLAGS="$WFLAGS $try_flags"