summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJay Berkenbilt <ejb@ql.org>2011-06-23 20:40:37 +0200
committerJay Berkenbilt <ejb@ql.org>2011-06-23 20:40:37 +0200
commita8a95fba47e32356d536671d6c5ebd82a6c4507c (patch)
tree277177fba7655067c595eaecc4e5654f2122ad6c /configure.ac
parente37d4d13e394ffdad89752113c884c7f25631bf3 (diff)
downloadqpdf-a8a95fba47e32356d536671d6c5ebd82a6c4507c.tar.zst
disable -Werror by default, don't strip shared libraries and executables during install
git-svn-id: svn+q:///qpdf/trunk@1058 71b93d88-0707-0410-a8cf-f5a4172ac649
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index bbb5d19a..ac543e12 100644
--- a/configure.ac
+++ b/configure.ac
@@ -114,12 +114,12 @@ if test "$BUILDRULES" != "msvc"; then
AC_MSG_CHECKING(for whether to use -Werror)
AC_ARG_ENABLE(werror,
AS_HELP_STRING([--enable-werror],
- [whether to use werror (default is yes if -Wall works)]),
+ [whether to use werror (default is no)]),
[if test "$enableval" = "yes"; then
qpdf_USE_WERROR=1;
else
qpdf_USE_WERROR=0;
- fi], [qpdf_USE_WERROR=$qpdf_USE_WALL])
+ fi], [qpdf_USE_WERROR=0])
if test "$qpdf_USE_WERROR" = "1"; then
AC_MSG_RESULT(yes)
CFLAGS="$CFLAGS -Werror"