summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJay Berkenbilt <ejb@ql.org>2012-06-24 20:59:44 +0200
committerJay Berkenbilt <ejb@ql.org>2012-06-24 21:20:01 +0200
commit4ef95dbda440e0aeffa26df40cc33d001e77f4c5 (patch)
treeaf688e3cc50b7f0485763b9a5cddc877171f0080 /configure.ac
parent2a057ac0d4053d2306f48bc9e89b0dcb1959b9da (diff)
downloadqpdf-4ef95dbda440e0aeffa26df40cc33d001e77f4c5.tar.zst
Suppress showing failed test output by default
Provide option to show test output if requested.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c1cf187c..21481311 100644
--- a/configure.ac
+++ b/configure.ac
@@ -212,6 +212,17 @@ AC_ARG_ENABLE(test-compare-images,
fi],
[SKIP_TEST_COMPARE_IMAGES=0])
+AC_SUBST(SHOW_FAILED_TEST_OUTPUT)
+AC_ARG_ENABLE(show-failed-test-output,
+ AS_HELP_STRING([--enable-show-failed-test-output],
+ [if specified, write failed test output to the console; useful for building on build servers where you can't easily open the test output files]),
+ [if test "$enableval" = "no"; then
+ SHOW_FAILED_TEST_OUTPUT=0
+ else
+ SHOW_FAILED_TEST_OUTPUT=1
+ fi],
+ [SHOW_FAILED_TEST_OUTPUT=0])
+
AC_ARG_WITH(docbook-xsl,
AS_HELP_STRING([--with-docbook-xsl=DIR],
[location of docbook 4.x xml stylesheets]),