summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJay Berkenbilt <ejb@ql.org>2017-08-11 10:56:22 +0200
committerJay Berkenbilt <ejb@ql.org>2017-08-11 10:56:22 +0200
commite7d0019bf48ac6b554d46a545242515db9d72644 (patch)
tree0b4047f2f02d3d1b1e613638d6d23ee910701ec5 /configure.ac
parent6247aaa57cb7d077086c48c7fa40069d924e53bf (diff)
downloadqpdf-e7d0019bf48ac6b554d46a545242515db9d72644.tar.zst
Generate libqpdf.map from autoconf
Rather than checking consistency of libqpdf.map, generate it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fd271214..36119999 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8,6 +8,7 @@ AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_FILES([autoconf.mk])
AC_CONFIG_FILES([manual/html.xsl manual/print.xsl])
AC_CONFIG_FILES([libqpdf.pc])
+AC_CONFIG_FILES([libqpdf.map])
AC_CONFIG_HEADERS([libqpdf/qpdf/qpdf-config.h])
AC_PROG_CC
@@ -16,6 +17,25 @@ AC_PROG_CXX
AC_HEADER_STDC
LT_INIT([win32-dll])
+# * If any interfaces have been removed or changed, or if any private
+# member variables or virtual functions have been added to any
+# class, we are not binary compatible. Increment LT_CURRENT, and set
+# LT_AGE and LT_REVISION to 0.
+#
+# * Otherwise, if any interfaces have been added since the last public
+# release, then increment LT_CURRENT and LT_AGE, and set LT_REVISION
+# to 0.
+#
+# * Otherwise, increment LT_REVISION
+
+# LT = libtool
+LT_CURRENT=17
+LT_REVISION=0
+LT_AGE=0
+AC_SUBST(LT_CURRENT)
+AC_SUBST(LT_REVISION)
+AC_SUBST(LT_AGE)
+
AC_ARG_ENABLE(insecure-random,
AS_HELP_STRING([--enable-insecure-random],
[whether to use stdlib's random number generator (default is no)]),