aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJay Berkenbilt <ejb@ql.org>2019-01-08 01:56:36 +0100
committerJay Berkenbilt <ejb@ql.org>2019-01-08 01:56:36 +0100
commit2d0336d8626da47e8e820682fe067a6f8ce88243 (patch)
tree4a6566145744c20e27b863dd5e751eeca0ebb439 /configure.ac
parente6f1e547718079ebc2b216a62a1e40af2ea1d471 (diff)
downloadqpdf-2d0336d8626da47e8e820682fe067a6f8ce88243.tar.zst
Add --disable-check-autofiles to configure
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 65f5ee08..fb76544e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11,13 +11,23 @@ AC_CONFIG_FILES([libqpdf.pc])
AC_CONFIG_FILES([libqpdf.map])
AC_CONFIG_HEADERS([libqpdf/qpdf/qpdf-config.h])
+AC_ARG_ENABLE(check-autofiles,
+ AS_HELP_STRING([--enable-check-autofiles],
+ [if specified, verify checksums on automatically generated files (default=yes); package maintainers may want to disable this]),
+ [if test "$enableval" = "no"; then
+ CHECK_AUTOFILES=0
+ else
+ CHECK_AUTOFILES=1
+ fi],
+ [CHECK_AUTOFILES=1])
+
# Check to see if automatically generated files are outdated and if we
# can update them.
AC_CHECK_PROG(AUTOCONF,autoconf,1,0)
AC_CHECK_PROG(AUTOHEADER,autoheader,1,0)
AC_CHECK_PROG(ACLOCAL,aclocal,1,0)
AC_CHECK_PROG(SHA256SUM,sha256sum,1,0)
-if test "$AUTOCONF$AUTOHEADER$ACLOCAL$SHA256SUM" = "1111"; then
+if test "$CHECK_AUTOFILES$AUTOCONF$AUTOHEADER$ACLOCAL$SHA256SUM" = "11111"; then
if ! sha256sum -c autofiles.sums; then
AC_MSG_ERROR(autofiles are autodated; rerun autogen.sh)
fi