aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJay Berkenbilt <ejb@ql.org>2019-01-11 04:28:15 +0100
committerJay Berkenbilt <ejb@ql.org>2019-01-11 04:35:08 +0100
commit4ecd1df6f2ecb98d388082b154497ed61aa11e18 (patch)
treebf43e8f5869c4c1e0e7f97dcc33a8dab28d7b70f /configure.ac
parentd24a120c7ffb4cbfd2dcebe63577d8704442f7bd (diff)
downloadqpdf-4ecd1df6f2ecb98d388082b154497ed61aa11e18.tar.zst
Add configure option AVOID_WINDOWS_HANDLE
If set, we avoid using Windows I/O HANDLE, which is disallowed in some versions of the Windows SDK, such as for Windows phones. QUtil::same_file will always return false in this case. Only applies to Windows builds.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fb76544e..dfef332f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -92,6 +92,21 @@ fi
AX_RANDOM_DEVICE
+AC_ARG_ENABLE(avoid-windows-handle,
+ AS_HELP_STRING([--enable-avoid-windows-handle],
+ [whether to avoid use of HANDLE, useful for some embedded Windows builds (default is no)]),
+ [if test "$enableval" = "yes"; then
+ qpdf_AVOID_HANDLE=1;
+ else
+ qpdf_AVOID_HANDLE=0;
+ fi], [qpdf_AVOID_HANDLE=0])
+if test "$qpdf_AVOID_HANDLE" = "1"; then
+ AC_MSG_RESULT(yes)
+ AC_DEFINE([AVOID_WINDOWS_HANDLE], [1], [Whether to avoid use of HANDLE in Windows])
+else
+ AC_MSG_RESULT(no)
+fi
+
USE_EXTERNAL_LIBS=0
AC_MSG_CHECKING(for whether to use external libraries distribution)
AC_ARG_ENABLE(external-libs,