aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJay Berkenbilt <ejb@ql.org>2009-10-23 18:44:13 +0200
committerJay Berkenbilt <ejb@ql.org>2009-10-23 18:44:13 +0200
commitcfc1f6fcac1f55aaca02792c69f130e6fde5c2d5 (patch)
tree5bc9f26545b1f75238471b9d6f6f4fad6193d837 /configure.ac
parentdcaeb6a89d51028cf229fc60ae0abc65f86f9f01 (diff)
downloadqpdf-cfc1f6fcac1f55aaca02792c69f130e6fde5c2d5.tar.zst
notes, version
git-svn-id: svn+q:///qpdf/trunk@893 71b93d88-0707-0410-a8cf-f5a4172ac649
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 1807d97c..94a1130d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@ dnl Process this file with autoconf to produce a configure script.
dnl This config.in requires autoconf 2.5 or greater.
AC_PREREQ(2.60)
-AC_INIT(qpdf,2.1.a1)
+AC_INIT(qpdf,2.1.rc1)
AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_FILES([autoconf.mk])
@@ -110,7 +110,7 @@ if test "$BUILDRULES" != "msvc"; then
fi
fi
-if test "$USE_EXTERNAL_LIBS" = "0"; then
+if test "$BUILDRULES" != "msvc"; then
AC_MSG_CHECKING(for whether to use -Werror)
AC_ARG_ENABLE(werror,
AS_HELP_STRING([--enable-werror],
@@ -318,9 +318,9 @@ fi
# Do this last so it doesn't interfere with other tests.
if test "$USE_EXTERNAL_LIBS" = "1"; then
- if test "$BUILDRULES" = "libtool"; then
- AC_MSG_ERROR([BUILDRULES=libtool is not supported when building external libraries])
- fi
+ # Don't actually check for the presence of this -- we document that
+ # the user can run this and then edit autoconf.mk if they have too
+ # much trouble getting it to work with a different compiler.
CPPFLAGS="$CPPFLAGS -Iexternal-libs/include"
LDFLAGS="$LDFLAGS -Lexternal-libs/lib-$BUILDRULES"
LIBS="$LIBS -lz -lpcre"