aboutsummaryrefslogtreecommitdiffstats
path: root/fuzz/CMakeLists.txt
diff options
context:
space:
mode:
authorm-holger <m-holger@kubitscheck.org>2024-01-17 11:39:06 +0100
committerm-holger <m-holger@kubitscheck.org>2024-01-17 11:39:06 +0100
commit6e3b7982dbcf8087374694253e0e248fbc6c6e3e (patch)
tree9dd7f6a56b669da65f3653ced2f1b449e3d4f79e /fuzz/CMakeLists.txt
parent0109e365decfdc2e8fbb920b4179d32daeeb96ae (diff)
downloadqpdf-6e3b7982dbcf8087374694253e0e248fbc6c6e3e.tar.zst
Fix incorrect handling of invalid negative object ids
Fix two errors introduced in #1110 and #1112. Since #1110, encountering the invalid indirect reference #1110 -2147483648 n R produces an integer underflow which, if undetected, immediately trigger a logic error. Since #1112, object -1 0 R may be incorrectly identified as an earlier generation of itself and deleted, invalidating a live iterator.
Diffstat (limited to 'fuzz/CMakeLists.txt')
-rw-r--r--fuzz/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/fuzz/CMakeLists.txt b/fuzz/CMakeLists.txt
index df1fa807..e4a8cf36 100644
--- a/fuzz/CMakeLists.txt
+++ b/fuzz/CMakeLists.txt
@@ -111,6 +111,8 @@ set(CORPUS_OTHER
37740.fuzz
57639.fuzz
65681.fuzz
+ 65773.fuzz
+ 65777.fuzz
)
set(CORPUS_DIR ${CMAKE_CURRENT_BINARY_DIR}/qpdf_corpus)