aboutsummaryrefslogtreecommitdiffstats
path: root/include/CMakeLists.txt
diff options
context:
space:
mode:
authorJay Berkenbilt <ejb@ql.org>2022-03-05 14:24:51 +0100
committerJay Berkenbilt <jberkenbilt@users.noreply.github.com>2022-03-19 00:53:18 +0100
commitb8aff90997116a84350018f88f1eabdaa368d11b (patch)
tree5ee781b03d3ffa81bfdd813e91f6324a75b266e6 /include/CMakeLists.txt
parent105862da3ea72c6763c26038d2e02cf243eb0798 (diff)
downloadqpdf-b8aff90997116a84350018f88f1eabdaa368d11b.tar.zst
Add cmake configuration files
Diffstat (limited to 'include/CMakeLists.txt')
-rw-r--r--include/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/include/CMakeLists.txt b/include/CMakeLists.txt
new file mode 100644
index 00000000..3110ba9c
--- /dev/null
+++ b/include/CMakeLists.txt
@@ -0,0 +1,12 @@
+set(qpdf_INCLUDE ${CMAKE_CURRENT_SOURCE_DIR} PARENT_SCOPE)
+
+# While globs are not considered best practice, it makes sense for
+# installation o header files. When compiling, you specify an entire
+# directory, so not doing the same at installation time creates a high
+# risk that forgetting to explicitly add a header to an installation
+# list would not be detected in CI or at any time until an end user
+# tries to build code.
+install(DIRECTORY qpdf
+ TYPE INCLUDE
+ COMPONENT ${COMPONENT_DEV}
+ FILES_MATCHING PATTERN "*.h" PATTERN "*.hh")