aboutsummaryrefslogtreecommitdiffstats
path: root/libqpdf/CMakeLists.txt
diff options
context:
space:
mode:
authorJay Berkenbilt <ejb@ql.org>2022-03-15 02:39:29 +0100
committerJay Berkenbilt <jberkenbilt@users.noreply.github.com>2022-03-19 00:53:18 +0100
commitacdf5b2e7a9b3074125bc95bfcf7e6abdc9704b4 (patch)
tree2606c1709893f0011837fe56bdc2ba3337e5440e /libqpdf/CMakeLists.txt
parent4c0addfe660fcda049ab1d79d337871c1df798f7 (diff)
downloadqpdf-acdf5b2e7a9b3074125bc95bfcf7e6abdc9704b4.tar.zst
Update process for ABI testing
Diffstat (limited to 'libqpdf/CMakeLists.txt')
-rw-r--r--libqpdf/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/libqpdf/CMakeLists.txt b/libqpdf/CMakeLists.txt
index 2d8c7b65..c5525db2 100644
--- a/libqpdf/CMakeLists.txt
+++ b/libqpdf/CMakeLists.txt
@@ -579,3 +579,13 @@ if(INSTALL_CMAKE_PACKAGE)
${CMAKE_CURRENT_BINARY_DIR}/qpdfConfig.cmake
DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/qpdf)
endif()
+
+if(CHECK_SIZES AND BUILD_SHARED_LIBS AND (CMAKE_SYSTEM_NAME STREQUAL "Linux"))
+ # We can only do this check on a system with ELF shared libraries.
+ # Since this is a maintainer-only option, testing for Linux is a
+ # close enough approximation.
+ add_test(
+ NAME check-sizes
+ COMMAND ${qpdf_SOURCE_DIR}/check_abi check-sizes
+ --lib $<TARGET_FILE:libqpdf>)
+endif()