aboutsummaryrefslogtreecommitdiffstats
path: root/libqpdf/CMakeLists.txt
diff options
context:
space:
mode:
authorJay Berkenbilt <ejb@ql.org>2022-03-23 15:52:40 +0100
committerJay Berkenbilt <ejb@ql.org>2022-03-23 15:52:40 +0100
commitf8e97e0ed56cf5942ef36d34f1c64185c9c84d5c (patch)
treeab4d3f98faf7af75ad0a13f9ba2bab70fd6689d5 /libqpdf/CMakeLists.txt
parent336062930d8b51538b39a70ea9a4519ebe45fcc8 (diff)
downloadqpdf-f8e97e0ed56cf5942ef36d34f1c64185c9c84d5c.tar.zst
Put spaces around version constraint in pkg-config (fixes #677)
Also add a pkg-config runtime test that would have caught the error.
Diffstat (limited to 'libqpdf/CMakeLists.txt')
-rw-r--r--libqpdf/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/libqpdf/CMakeLists.txt b/libqpdf/CMakeLists.txt
index 0875ccd4..be333b12 100644
--- a/libqpdf/CMakeLists.txt
+++ b/libqpdf/CMakeLists.txt
@@ -207,7 +207,7 @@ if(USE_IMPLICIT_CRYPTO OR REQUIRE_CRYPTO_OPENSSL)
if(pc_openssl_FOUND)
set(USE_CRYPTO_OPENSSL ON)
set(FOUND_CRYPTO ON)
- set(CRYPTO_PKG "${CRYPTO_PKG}, openssl>=1.1.0")
+ set(CRYPTO_PKG "${CRYPTO_PKG}, openssl >= 1.1.0")
else()
find_path(OPENSSL_H_PATH openssl/evp.h)
find_library(OPENSSL_LIB_PATH crypto)