aboutsummaryrefslogtreecommitdiffstats
path: root/libqpdf/CMakeLists.txt
diff options
context:
space:
mode:
authorJay Berkenbilt <ejb@ql.org>2022-05-08 19:42:16 +0200
committerJay Berkenbilt <ejb@ql.org>2022-05-16 19:41:40 +0200
commit4fe2e06b4787ffb639f965ac840b51018308ec07 (patch)
tree667474624e264384d544cbed4324b909478f3450 /libqpdf/CMakeLists.txt
parented6130036c65124cb236e709201330404a4b1d72 (diff)
downloadqpdf-4fe2e06b4787ffb639f965ac840b51018308ec07.tar.zst
Add --create-from-json and --update-from-json arguments
Also add stubs for top-level QPDF methods (createFromJSON, updateFromJSON)
Diffstat (limited to 'libqpdf/CMakeLists.txt')
-rw-r--r--libqpdf/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/libqpdf/CMakeLists.txt b/libqpdf/CMakeLists.txt
index aa7b1fd0..1777bb08 100644
--- a/libqpdf/CMakeLists.txt
+++ b/libqpdf/CMakeLists.txt
@@ -97,6 +97,7 @@ set(libqpdf_SOURCES
QPDF_Stream.cc
QPDF_String.cc
QPDF_encryption.cc
+ QPDF_json.cc
QPDF_linearization.cc
QPDF_optimization.cc
QPDF_pages.cc