aboutsummaryrefslogtreecommitdiffstats
path: root/libqpdf/CMakeLists.txt
diff options
context:
space:
mode:
authorJay Berkenbilt <ejb@ql.org>2022-09-05 15:15:14 +0200
committerJay Berkenbilt <ejb@ql.org>2022-09-06 00:52:59 +0200
commit6c61be00e8366d467e7e4c82a6d91a4d074a1181 (patch)
tree610ccf8c637cdd778e734c15d1e94bcd68e9f30f /libqpdf/CMakeLists.txt
parent5d65e73ca719fdb921f627e3789920ea60c66f01 (diff)
downloadqpdf-6c61be00e8366d467e7e4c82a6d91a4d074a1181.tar.zst
Rename QPDFObject -> QPDFValueProxy
This is in preparation for restoring a QPDFObject.hh to ease the transition on qpdf_object_type_e. This commit was created by * Renaming QPDFObject.cc and QPDFObject.hh * Replacing QPDFObject\b with QPDFValueProxy (where \b is word boundary) * Running format-code * Manually resorting files in libqpdf/CMakeLists.txt * Manually refilling the comment in QPDF.hh near class Resolver
Diffstat (limited to 'libqpdf/CMakeLists.txt')
-rw-r--r--libqpdf/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/libqpdf/CMakeLists.txt b/libqpdf/CMakeLists.txt
index 686ea04a..95024c64 100644
--- a/libqpdf/CMakeLists.txt
+++ b/libqpdf/CMakeLists.txt
@@ -72,7 +72,6 @@ set(libqpdf_SOURCES
QPDFMatrix.cc
QPDFNameTreeObjectHelper.cc
QPDFNumberTreeObjectHelper.cc
- QPDFObject.cc
QPDFObjectHandle.cc
QPDFObjGen.cc
QPDFOutlineDocumentHelper.cc
@@ -86,6 +85,7 @@ set(libqpdf_SOURCES
QPDFTokenizer.cc
QPDFUsage.cc
QPDFValue.cc
+ QPDFValueProxy.cc
QPDFWriter.cc
QPDFXRefEntry.cc
QPDF_Array.cc