aboutsummaryrefslogtreecommitdiffstats
path: root/qpdf/CMakeLists.txt
diff options
context:
space:
mode:
authorJay Berkenbilt <ejb@ql.org>2022-09-01 00:40:15 +0200
committerJay Berkenbilt <ejb@ql.org>2022-09-01 22:15:54 +0200
commit4f4b908605a0c0e9cf3fc568302b074801eb7419 (patch)
tree57a47a647569cff6456bcf6e050998a2edc4c675 /qpdf/CMakeLists.txt
parent3d029fb17ef6b8ea9094394741f103608f698bad (diff)
downloadqpdf-4f4b908605a0c0e9cf3fc568302b074801eb7419.tar.zst
Add a file with arrays with lots of nulls to the test suite
A bug was fixed between qpdf 8.4.2 and 9.0.0 regarding this type of file (see #305 and #311), but it was necessary to retest after some major refactoring work at the lexical and parsing layers. This lays the groundwork for including this in performance benchmarks and in the qpdf test suite rather than having to keep a large, non-redistributable file around. 20 arrays of 20K nulls is plenty for performance memory testing and doesn't take too long to run. Compared to qpdf 8.4.2, in qpdf 11.0.0, the file generated here uses 3% of the RAM and runs over 4 times faster.
Diffstat (limited to 'qpdf/CMakeLists.txt')
-rw-r--r--qpdf/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/qpdf/CMakeLists.txt b/qpdf/CMakeLists.txt
index bc4ddf11..cf2f53c4 100644
--- a/qpdf/CMakeLists.txt
+++ b/qpdf/CMakeLists.txt
@@ -5,6 +5,7 @@ set(MAIN_CXX_PROGRAMS
sizes
test_driver
test_large_file
+ test_many_nulls
test_parsedoffset
test_pdf_doc_encoding
test_pdf_unicode