aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 72bf5a95..3e50f0b5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -305,6 +305,10 @@ if(GENERATE_AUTO_JOB)
add_custom_target(auto_job_files ALL DEPENDS ${auto_job_outputs})
endif()
+add_test(
+ NAME check-assert
+ COMMAND perl ${qpdf_SOURCE_DIR}/check_assert)
+
# add_subdirectory order affects test order
add_subdirectory(include)
add_subdirectory(libqpdf)