aboutsummaryrefslogtreecommitdiffstats
path: root/compare-for-test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'compare-for-test/CMakeLists.txt')
-rw-r--r--compare-for-test/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/compare-for-test/CMakeLists.txt b/compare-for-test/CMakeLists.txt
new file mode 100644
index 00000000..c5ebbbbc
--- /dev/null
+++ b/compare-for-test/CMakeLists.txt
@@ -0,0 +1,15 @@
+# This directory is called compare-for-test rather than
+# qpdf-test-compare to make shell completion easier.
+add_executable(qpdf-test-compare qpdf-test-compare.cc)
+target_link_libraries(qpdf-test-compare libqpdf)
+
+add_test(
+ NAME compare-for-test
+ COMMAND ${RUN_QTEST}
+ --top ${qpdf_SOURCE_DIR}
+ --bin $<TARGET_FILE_DIR:qpdf-test-compare>
+ --bin $<TARGET_FILE_DIR:libqpdf> # for Windows to find DLL
+ --code ${qpdf_SOURCE_DIR}/compare-for-test
+ --color ${QTEST_COLOR}
+ --show-on-failure ${SHOW_FAILED_TEST_OUTPUT}
+ --tc "${qpdf_SOURCE_DIR}/compare-for-test/*.cc")