aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 1 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index f9c0f6a6..fd271214 100644
--- a/configure.ac
+++ b/configure.ac
@@ -82,8 +82,6 @@ fi
if test "$BUILD_INTERNAL_LIBS" = "0"; then
AC_CHECK_HEADER(zlib.h,,[MISSING_ZLIB_H=1; MISSING_ANY=1])
AC_SEARCH_LIBS(deflate,z zlib,,[MISSING_ZLIB=1; MISSING_ANY=1])
- AC_CHECK_HEADER(pcre.h,,[MISSING_PCRE_H=1; MISSING_ANY=1])
- AC_SEARCH_LIBS(pcre_compile,pcre,,[MISSING_PCRE=1; MISSING_ANY=1])
fi
if test "x$qpdf_OS_SECURE_RANDOM" = "x1"; then
@@ -453,14 +451,6 @@ if test "$MISSING_ZLIB" = "1"; then
AC_MSG_WARN(unable to find required library z (or zlib))
fi
-if test "$MISSING_PCRE_H" = "1"; then
- AC_MSG_WARN(unable to find required header pcre.h)
-fi
-
-if test "$MISSING_PCRE" = "1"; then
- AC_MSG_WARN(unable to find required library pcre)
-fi
-
if test "$MISSING_DOCBOOK_FO" = "1"; then
AC_MSG_WARN(docbook fo stylesheets are required to build PDF documentation)
fi
@@ -497,7 +487,7 @@ if test "$USE_EXTERNAL_LIBS" = "1"; then
# much trouble getting it to work with a different compiler.
CPPFLAGS="$CPPFLAGS -Iexternal-libs/include"
LDFLAGS="$LDFLAGS -Lexternal-libs/lib-$BUILDRULES$WINDOWS_WORDSIZE"
- LIBS="$LIBS -lz -lpcre"
+ LIBS="$LIBS -lz"
fi
AC_OUTPUT