summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Gassner <justin.gassner@mailbox.org>2020-02-15 23:05:51 +0100
committerJustin Gassner <justin.gassner@mailbox.org>2020-02-15 23:05:51 +0100
commit0dc1fb091cd8f3445dc8b284187d7f8ee793d99b (patch)
treef9d59aee70fd58424679aa718c1e0641638ff3e2
parentb33d9ffea0d97781d7643d008c79cd710e61bcb6 (diff)
downloadpackages-0dc1fb091cd8f3445dc8b284187d7f8ee793d99b.tar.zst
Add git to makedepends when needed
-rw-r--r--mpop/PKGBUILD2
-rw-r--r--mpv/PKGBUILD2
-rw-r--r--msmtp/PKGBUILD2
-rw-r--r--mutt/PKGBUILD1
-rw-r--r--pass/PKGBUILD1
-rw-r--r--vifm/PKGBUILD1
6 files changed, 6 insertions, 3 deletions
diff --git a/mpop/PKGBUILD b/mpop/PKGBUILD
index 5839d49..fc93e33 100644
--- a/mpop/PKGBUILD
+++ b/mpop/PKGBUILD
@@ -9,7 +9,7 @@ arch=('x86_64')
url="https://marlam.de/$_pkgname/"
license=('GPL3')
depends=('gnutls')
-makedepends=('texlive-plainextra')
+makedepends=('git' 'texlive-plainextra')
provides=("$_pkgname")
conflicts=("$_pkgname")
source=("git+https://git.marlam.de/git/$_pkgname.git")
diff --git a/mpv/PKGBUILD b/mpv/PKGBUILD
index 958d86b..e31f910 100644
--- a/mpv/PKGBUILD
+++ b/mpv/PKGBUILD
@@ -10,7 +10,7 @@ arch=('x86_64')
license=('GPL')
url='https://mpv.io'
depends=('ffmpeg' 'libarchive' 'libxinerama' 'libxrandr' 'libxss' 'lua52')
-makedepends=('mesa' 'python-docutils')
+makedepends=('git' 'mesa' 'python-docutils')
optdepends=('youtube-dl: for video-sharing websites playback')
provides=("$_pkgname")
conflicts=("$_pkgname")
diff --git a/msmtp/PKGBUILD b/msmtp/PKGBUILD
index b343d15..3c7c3b6 100644
--- a/msmtp/PKGBUILD
+++ b/msmtp/PKGBUILD
@@ -9,7 +9,7 @@ arch=('x86_64')
url="https://marlam.de/$_pkgname/"
license=('GPL3')
depends=('gnutls' 'gsasl')
-makedepends=('texlive-plainextra')
+makedepends=('git' 'texlive-plainextra')
provides=("$_pkgname")
conflicts=("$_pkgname")
source=("git+https://git.marlam.de/git/$_pkgname.git")
diff --git a/mutt/PKGBUILD b/mutt/PKGBUILD
index b906a28..77ec005 100644
--- a/mutt/PKGBUILD
+++ b/mutt/PKGBUILD
@@ -9,6 +9,7 @@ arch=('x86_64')
url='http://www.mutt.org'
license=('GPL')
depends=('gpgme' 'libidn')
+makedepends=('git')
source=("git+https://gitlab.com/muttmua/mutt.git")
sha256sums=('SKIP')
diff --git a/pass/PKGBUILD b/pass/PKGBUILD
index b3f2116..3ecdff3 100644
--- a/pass/PKGBUILD
+++ b/pass/PKGBUILD
@@ -11,6 +11,7 @@ license=('GPL2')
depends=('bash' 'gnupg' 'pwgen' 'xclip')
optdepends=('git: for Git support'
'dmenu: for passmenu')
+makedepends=('git')
provides=("$_pkgname")
conflicts=("$_pkgname")
source=("git+https://git.jxir.de/$_pkgname")
diff --git a/vifm/PKGBUILD b/vifm/PKGBUILD
index 916a9d9..3b7c087 100644
--- a/vifm/PKGBUILD
+++ b/vifm/PKGBUILD
@@ -10,6 +10,7 @@ url="https://vifm.info/"
license=('GPL')
depends=('file' 'bash')
optdepends=('perl: vifm-convert-dircolors')
+makedepends=('git')
provides=("$_pkgname")
conflicts=("$_pkgname")
source=("git+https://github.com/$_pkgname/$_pkgname.git")