summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Gassner <justin.gassner@web.de>2017-10-07 16:24:59 +0200
committerJustin Gassner <justin.gassner@web.de>2017-10-07 16:24:59 +0200
commit33ef395470e723eac3146655eace0843d3eb2ed4 (patch)
tree0b394a0c3a10d0e384ad8ea91dba8c51640eee8b
downloadpackages-33ef395470e723eac3146655eace0843d3eb2ed4.tar.zst
Initial commit
-rw-r--r--ffmpeg/PKGBUILD54
-rw-r--r--mpop/PKGBUILD44
-rw-r--r--mpop/change-configuration-file-location.patch25
-rw-r--r--msmtp/PKGBUILD44
-rw-r--r--msmtp/change-configuration-file-location.patch25
-rw-r--r--mutt/PKGBUILD44
-rw-r--r--neovim/PKGBUILD50
-rw-r--r--vifm/PKGBUILD36
8 files changed, 322 insertions, 0 deletions
diff --git a/ffmpeg/PKGBUILD b/ffmpeg/PKGBUILD
new file mode 100644
index 0000000..1c97636
--- /dev/null
+++ b/ffmpeg/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Justin Gassner <justin.gassner@web.de>
+
+_pkgname=ffmpeg
+pkgname=$_pkgname-jxir
+pkgver=3.3.4
+pkgrel=1
+epoch=1
+pkgdesc='Complete solution to record, convert and stream audio and video'
+arch=('i686' 'x86_64')
+url='https://ffmpeg.org/'
+license=('GPL3')
+depends=('alsa-lib' 'bzip2' 'fontconfig' 'libass' 'zlib')
+makedepends=('yasm')
+provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
+ 'libavutil.so' 'libpostproc.so' 'libswresample.so'
+ 'libswscale.so' 'ffmpeg')
+conflicts=('ffmpeg')
+source=("http://ffmpeg.org/releases/$_pkgname-$pkgver.tar.xz"{,.asc})
+sha256sums=('98b97e1b908dfeb6aeb6d407e5a5eacdfc253a40c2d195f5867ed2d1d46ea957'
+ 'SKIP')
+validpgpkeys=('FCF986EA15E6E293A5644F10B4322F04D67658D8')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ ./configure \
+ --prefix='/usr' \
+ --enable-gpl \
+ --enable-version3 \
+ --disable-static \
+ --enable-shared \
+ --disable-runtime-cpudetect \
+ --disable-swscale-alpha \
+ --disable-ffplay \
+ --disable-ffserver \
+ --disable-doc \
+ --disable-network \
+ --disable-everything \
+ --enable-encoder=libvorbis \
+ --enable-decoder=aac,h264,libvorbis \
+ --enable-muxer=mp4,ogg \
+ --enable-demuxer=aac,ass,h264,matroska,mov,ogg \
+ --enable-parser=aac,h264,vorbis \
+ --enable-protocol=file \
+ --enable-libass \
+ --enable-libfontconfig \
+ --enable-libfreetype \
+ --disable-debug
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install install-man
+}
diff --git a/mpop/PKGBUILD b/mpop/PKGBUILD
new file mode 100644
index 0000000..fd499fb
--- /dev/null
+++ b/mpop/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Justin Gassner <justin.gassner@web.de>
+
+_pkgname=mpop
+pkgname=$_pkgname-jxir
+pkgver=1.2.6
+pkgrel=1
+pkgdesc='A small, fast POP3 client'
+arch=('i686' 'x86_64')
+url="http://$_pkgname.sourceforge.net"
+license=('GPL3')
+depends=('gsasl')
+makedepends=('texlive-plainextra')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("http://downloads.sourceforge.net/$_pkgname/$_pkgname-$pkgver.tar.xz"{,.sig}
+ 'change-configuration-file-location.patch')
+sha256sums=('9fec7a9dd08fc0f04bf6178bc651b036d1fe0e46903146f38a8d182887e9315c'
+ 'SKIP'
+ 'ca36ec82129c14a1f69d51beb89fcd2a6a79ec4d2eac7f4248207c9aaf2229a4')
+validpgpkeys=('2F788CDEF4181652720EF132F4926138953E5294') # Martin Lambers
+
+prepare() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ patch -p1 -i "$srcdir/change-configuration-file-location.patch"
+}
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ ./configure \
+ --prefix=/usr \
+ --disable-nls \
+ --with-tls=gnutls \
+ --without-libsecret
+ make
+ make -C doc pdf
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" -C doc install-pdf
+ install -D -m644 doc/*.example "$pkgdir/usr/share/doc/$_pkgname/"
+ install -D -m644 "scripts/vim/$_pkgname.vim" "$pkgdir/usr/share/nvim/runtime/syntax/$_pkgname.vim"
+}
diff --git a/mpop/change-configuration-file-location.patch b/mpop/change-configuration-file-location.patch
new file mode 100644
index 0000000..4deffb5
--- /dev/null
+++ b/mpop/change-configuration-file-location.patch
@@ -0,0 +1,25 @@
+From d1127c5cef14cb25fcae305071d83d5f89f810d8 Mon Sep 17 00:00:00 2001
+From: Justin Gassner <justin.gassner@web.de>
+Date: Wed, 18 May 2016 22:46:31 +0200
+Subject: [PATCH] Change configuration file location
+
+---
+ src/mpop.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/mpop.c b/src/mpop.c
+index 2770cf9..60b155f 100644
+--- a/src/mpop.c
++++ b/src/mpop.c
+@@ -97,7 +97,7 @@ extern int optind;
+ #define USERNETRCFILE "_netrc"
+ #define SYSNETRCFILE "netrc"
+ #else /* UNIX */
+-#define CONFFILE ".mpoprc"
++#define CONFFILE ".config/mpop"
+ #define UIDLSFILE ".mpop_uidls/%U_at_%H"
+ #define USERNETRCFILE ".netrc"
+ #define SYSNETRCFILE "netrc"
+--
+2.8.2
+
diff --git a/msmtp/PKGBUILD b/msmtp/PKGBUILD
new file mode 100644
index 0000000..06606a6
--- /dev/null
+++ b/msmtp/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Justin Gassner <justin.gassner@web.de>
+
+_pkgname=msmtp
+pkgname=$_pkgname-jxir
+pkgver=1.6.6
+pkgrel=1
+pkgdesc='A small, fast SMTP client'
+arch=('i686' 'x86_64')
+url="http://$_pkgname.sourceforge.net"
+license=('GPL3')
+depends=('gsasl')
+makedepends=('texlive-plainextra')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("http://downloads.sourceforge.net/$_pkgname/$_pkgname-$pkgver.tar.xz"{,.sig}
+ 'change-configuration-file-location.patch')
+sha256sums=('da15db1f62bd0201fce5310adb89c86188be91cd745b7cb3b62b81a501e7fb5e'
+ 'SKIP'
+ '46bb7505e7a2298846cb03ba4cacc4b1cabd09bb425715a02d2c3ec1a7780ad4')
+validpgpkeys=('2F788CDEF4181652720EF132F4926138953E5294') # Martin Lambers
+
+prepare() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ patch -p1 -i "$srcdir/change-configuration-file-location.patch"
+}
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ ./configure \
+ --prefix=/usr \
+ --disable-nls \
+ --with-tls=gnutls \
+ --without-libsecret
+ make
+ make -C doc pdf
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" -C doc install-pdf
+ install -Dm644 doc/*.example "$pkgdir/usr/share/doc/$_pkgname/"
+ install -Dm644 "scripts/vim/$_pkgname.vim" "$pkgdir/usr/share/nvim/runtime/syntax/$_pkgname.vim"
+}
diff --git a/msmtp/change-configuration-file-location.patch b/msmtp/change-configuration-file-location.patch
new file mode 100644
index 0000000..4284470
--- /dev/null
+++ b/msmtp/change-configuration-file-location.patch
@@ -0,0 +1,25 @@
+From 9ac163f8fe8d7fceb215b3a39db51f2610856cc5 Mon Sep 17 00:00:00 2001
+From: Justin Gassner <justin.gassner@web.de>
+Date: Wed, 18 May 2016 23:05:49 +0200
+Subject: [PATCH] Change configuration file location
+
+---
+ src/msmtp.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/msmtp.c b/src/msmtp.c
+index 3e549ae..9e3b7f5 100644
+--- a/src/msmtp.c
++++ b/src/msmtp.c
+@@ -89,7 +89,7 @@ extern int optind;
+ #define USERNETRCFILE "_netrc"
+ #else /* UNIX */
+ #define SYSCONFFILE "msmtprc"
+-#define USERCONFFILE ".msmtprc"
++#define USERCONFFILE ".config/msmtp"
+ #define SYSNETRCFILE "netrc"
+ #define USERNETRCFILE ".netrc"
+ #endif
+--
+2.8.2
+
diff --git a/mutt/PKGBUILD b/mutt/PKGBUILD
new file mode 100644
index 0000000..898fd42
--- /dev/null
+++ b/mutt/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Justin Gassner <justin.gassner@web.de>
+
+_pkgname=mutt
+pkgname=$_pkgname-jxir
+pkgver=1.9.1
+pkgrel=1
+pkgdesc='Small but very powerful text-based mail client'
+arch=('i686' 'x86_64')
+url='http://www.mutt.org'
+license=('GPL')
+depends=('gpgme' 'libidn' 'ncurses')
+source=("http://ftp.mutt.org/pub/mutt/$_pkgname-$pkgver.tar.gz"{,.asc})
+sha256sums=('749b83a96373c6e2101ebe8c4b9a651735e02c478edb750750a5146a15d91bb1'
+ 'SKIP')
+validpgpkeys=('8975A9B33AA37910385C5308ADEF768480316BDA') # Kevin McCarthy
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-gpgme \
+ --disable-pgp \
+ --enable-sidebar \
+ --enable-hcache \
+ --disable-nls \
+ --disable-full-doc \
+ --with-curses=/usr \
+ --with-regex
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ rm "$pkgdir"/etc/Muttrc.dist
+ rm "$pkgdir"/etc/mime.types{,.dist}
+ rm "$pkgdir"/usr/bin/{flea,muttbug}
+ rm "$pkgdir"/usr/share/man/man1/{flea,muttbug,pgpewrap,pgpring}.1
+ rm -r "$pkgdir"/usr/share/doc/mutt/samples/
+ rm "$pkgdir"/usr/share/doc/mutt/{applying-patches.txt,devel-notes.txt,patch-notes.txt,PGP-Notes.txt,smime-notes.txt}
+ rm "$pkgdir"/usr/share/doc/mutt/{ChangeLog,COPYRIGHT,GPL,INSTALL,NEWS,README,README.SECURITY,README.SSL,TODO}
+ rm "$pkgdir"/usr/share/doc/mutt/{manual.txt,manual.html}
+}
diff --git a/neovim/PKGBUILD b/neovim/PKGBUILD
new file mode 100644
index 0000000..38ded77
--- /dev/null
+++ b/neovim/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Justin Gassner <justin.gassner@web.de>
+
+_pkgname=neovim
+pkgname=$_pkgname-jxir
+pkgver=0.2.0.r922.g01487d438
+pkgrel=1
+pkgdesc='Fork of Vim aiming to improve user experience, plugins, and GUIs'
+arch=('i686' 'x86_64')
+url='https://neovim.io'
+license=('custom:neovim')
+depends=('jemalloc' 'libtermkey' 'libuv' 'libvterm' 'luajit' 'msgpack-c' 'unibilium')
+makedepends=('cmake' 'git' 'gperf' 'lua51-lpeg' 'lua51-mpack')
+optdepends=('python2-neovim: for Python 2 plugin support (see :help provider-python)'
+ 'python-neovim: for Python 3 plugin support (see :help provider-python)'
+ 'ruby-neovim: for Ruby plugin support (see :help provider-ruby)'
+ 'xclip: for clipboard support (or xsel) (see :help provider-clipboard)'
+ 'xsel: for clipboard support (or xclip) (see :help provider-clipboard)')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+https://github.com/$_pkgname/$_pkgname.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ mkdir -p "$_pkgname/build"
+ cd "$_pkgname/build"
+ cmake -G 'Unix Makefiles' \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DENABLE_JEMALLOC=ON \
+ ..
+ make
+}
+
+check() {
+ cd "$_pkgname/build"
+ ./bin/nvim --version
+ ./bin/nvim --headless -u NONE -i NONE -c ':quit'
+}
+
+package() {
+ cd "$_pkgname/build"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 ../LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+ ln -s nvim "$pkgdir/usr/bin/vim"
+}
diff --git a/vifm/PKGBUILD b/vifm/PKGBUILD
new file mode 100644
index 0000000..ab94e25
--- /dev/null
+++ b/vifm/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Justin Gassner <justin.gassner@web.de>
+
+_pkgname=vifm
+pkgname=$_pkgname-jxir
+pkgver=0.9.r336.g8930e8aa
+pkgrel=1
+pkgdesc='Ncurses based file manager with vi like keybindings'
+arch=('i686' 'x86_64')
+url='https://vifm.info'
+license=('GPL')
+depends=('file' 'ncurses')
+optdepends=('perl: vifm-convert-dircolors')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+https://github.com/$_pkgname/$_pkgname.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/v//g'
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ ./configure \
+ --prefix=/usr \
+ --disable-desktop-files \
+ --without-gtk \
+ --without-X11
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make DESTDIR="$pkgdir" install
+}