summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Gassner <justin.gassner@web.de>2017-12-27 15:30:51 +0100
committerJustin Gassner <justin.gassner@web.de>2017-12-27 15:30:51 +0100
commit59a0be02de50f3aed353e41bd560f2759ce494b6 (patch)
tree8147aecf2a9bc1e4dfdb7c6089bb884f2c0b749a
parent4cd3ae381241a290b345d8867965153e6c00c4d1 (diff)
downloadpackages-59a0be02de50f3aed353e41bd560f2759ce494b6.tar.zst
Add dwm and st
-rw-r--r--dwm/PKGBUILD41
-rw-r--r--st/PKGBUILD41
2 files changed, 82 insertions, 0 deletions
diff --git a/dwm/PKGBUILD b/dwm/PKGBUILD
new file mode 100644
index 0000000..e0e0fac
--- /dev/null
+++ b/dwm/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Justin Gassner <justin.gassner@web.de>
+
+_pkgname=dwm
+pkgname=$_pkgname-jxir
+pkgver=6.1.40.g7eb87fe
+pkgrel=1
+pkgdesc='A dynamic window manager for X'
+arch=('x86_64')
+url="https://$_pkgname.suckless.org"
+license=('MIT')
+depends=('dmenu' 'freetype2' 'libx11' 'libxft' 'libxinerama' 'st')
+makedepends=('git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+https://git.jxir.de/$_pkgname")
+sha256sums=('SKIP')
+
+pkgver(){
+ cd "$_pkgname"
+ git describe --tags | sed 's/-/./g'
+}
+
+prepare() {
+ cd "$_pkgname"
+ for branch in noborder pertag fancybar config; do
+ git merge --no-edit origin/$branch
+ done
+ mv config.def.h config.h
+}
+
+build() {
+ cd "$_pkgname"
+ make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11 FREETYPEINC=/usr/include/freetype2
+}
+
+package() {
+ cd "$_pkgname"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+ install -Dm644 README "$pkgdir/usr/share/doc/$_pkgname/README"
+}
diff --git a/st/PKGBUILD b/st/PKGBUILD
new file mode 100644
index 0000000..9bd25ef
--- /dev/null
+++ b/st/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Justin Gassner <justin.gassner@web.de>
+
+_pkgname=st
+pkgname=$_pkgname-jxir
+pkgver=0.7.48.g6547872
+pkgrel=1
+pkgdesc='A simple virtual terminal emulator for X'
+arch=('x86_64')
+url="https://$_pkgname.suckless.org"
+license=('MIT')
+depends=('libxext' 'libxft')
+makedepends=('ncurses' 'git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+https://git.jxir.de/$_pkgname")
+sha256sums=('SKIP')
+
+pkgver(){
+ cd "$_pkgname"
+ git describe --tags | sed 's/-/./g'
+}
+
+prepare() {
+ cd "$_pkgname"
+ for branch in no-bold-colors solarized-dark scrollback config; do
+ git merge --no-edit origin/$branch
+ done
+ mv config.def.h config.h
+}
+
+build() {
+ cd "$_pkgname"
+ make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11
+}
+
+package() {
+ cd "$_pkgname"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+ install -Dm644 README "$pkgdir/usr/share/doc/$_pkgname/README"
+}