summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Gassner <justin.gassner@mailbox.org>2019-09-26 12:35:42 +0200
committerJustin Gassner <justin.gassner@mailbox.org>2019-09-26 12:35:42 +0200
commit7c8e6ef0c778fdf960d3df257cedd63e2c58d9a6 (patch)
tree5e41b9f4de8ac3ce9996f2894547bab64d2d2bbb
parentd5ce6ba8e50b7fddfe7c0883dec7fdb3fb4cff61 (diff)
downloadpackages-7c8e6ef0c778fdf960d3df257cedd63e2c58d9a6.tar.zst
Add youtube-dl
-rw-r--r--.gitignore1
-rw-r--r--youtube-dl/PKGBUILD36
2 files changed, 37 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
index b784492..14f27a0 100644
--- a/.gitignore
+++ b/.gitignore
@@ -13,3 +13,4 @@ pass/pass
slock/slock
st/st
vifm/vifm
+youtube/youtube
diff --git a/youtube-dl/PKGBUILD b/youtube-dl/PKGBUILD
new file mode 100644
index 0000000..8045bb2
--- /dev/null
+++ b/youtube-dl/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Justin Gassner <justin.gassner@mailbox.org>
+
+_pkgname=youtube-dl
+pkgname=$_pkgname-jxir
+pkgver=2019.09.12.1.r18.g33c1c7d80
+pkgrel=1
+pkgdesc='A small command-line program to download videos from YouTube.com and a few more sites'
+arch=('any')
+url='https://github.com/rg3/youtube-dl'
+license=('custom')
+depends=('python')
+makedepends=('git' 'python-setuptools' 'pandoc')
+optdepends=('ffmpeg: for video post-processing'
+ 'rtmpdump: for rtmp streams support'
+ 'atomicparsley: for embedding thumbnails into m4a files'
+ 'phantomjs: for openload support')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=('git+https://github.com/rg3/youtube-dl.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ make pypi-files
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}