summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Gassner <justin.gassner@mailbox.org>2019-09-26 11:46:36 +0200
committerJustin Gassner <justin.gassner@mailbox.org>2019-09-26 11:46:36 +0200
commita25e3e1f53066438f8b34893598e76ca4767db75 (patch)
treecd26c02230d5d364dcea80fc3f0badd26ebb0ed4
parent745508cac0b8f3df3f5c05a1088ccaf15e8d50a6 (diff)
downloadpackages-a25e3e1f53066438f8b34893598e76ca4767db75.tar.zst
fix dependencies
-rw-r--r--dmenu/PKGBUILD2
-rw-r--r--dwm/PKGBUILD2
-rw-r--r--neovim/PKGBUILD6
-rw-r--r--slock/PKGBUILD4
-rw-r--r--st/PKGBUILD4
-rw-r--r--vifm/PKGBUILD2
6 files changed, 10 insertions, 10 deletions
diff --git a/dmenu/PKGBUILD b/dmenu/PKGBUILD
index bb69dfc..060cbfa 100644
--- a/dmenu/PKGBUILD
+++ b/dmenu/PKGBUILD
@@ -8,7 +8,7 @@ pkgdesc='Generic menu for X'
arch=('x86_64')
url="https://tools.suckless.org/$_pkgname"
license=('MIT')
-depends=('freetype2' 'libxft' 'libxinerama' 'sh')
+depends=('libxft' 'libxinerama')
makedepends=('git')
provides=("$_pkgname")
conflicts=("$_pkgname")
diff --git a/dwm/PKGBUILD b/dwm/PKGBUILD
index 048b740..996c3a7 100644
--- a/dwm/PKGBUILD
+++ b/dwm/PKGBUILD
@@ -8,7 +8,7 @@ pkgdesc='A dynamic window manager for X'
arch=('x86_64')
url="https://$_pkgname.suckless.org"
license=('MIT')
-depends=('dmenu' 'freetype2' 'libx11' 'libxft' 'libxinerama' 'st')
+depends=('libxft' 'libxinerama')
makedepends=('git')
provides=("$_pkgname")
conflicts=("$_pkgname")
diff --git a/neovim/PKGBUILD b/neovim/PKGBUILD
index bf391cc..f86fe08 100644
--- a/neovim/PKGBUILD
+++ b/neovim/PKGBUILD
@@ -2,14 +2,14 @@
_pkgname=neovim
pkgname=$_pkgname-jxir
-pkgver=0.3.4.r188.g6e6bc3b6c
+pkgver=0.4.0.r64.gcb2520717
pkgrel=1
pkgdesc='Fork of Vim aiming to improve user experience, plugins, and GUIs'
arch=('x86_64')
url='https://neovim.io'
license=('custom:neovim')
-depends=('libtermkey' 'libuv' 'libvterm' 'luajit' 'msgpack-c' 'unibilium')
-makedepends=('cmake' 'git' 'gperf' 'lua51-lpeg' 'lua51-mpack' 'ninja')
+depends=('bash' 'libluv' 'libtermkey' 'libvterm' 'msgpack-c')
+makedepends=('cmake' 'git' 'gperf' 'lua51-lpeg' 'lua51-mpack')
optdepends=('python2-neovim: for Python 2 plugin support (see :help python)'
'python-neovim: for Python 3 plugin support (see :help python)'
'xclip: for clipboard support (or xsel) (see :help clipboard)'
diff --git a/slock/PKGBUILD b/slock/PKGBUILD
index 6c7be18..c3a1dd4 100644
--- a/slock/PKGBUILD
+++ b/slock/PKGBUILD
@@ -8,8 +8,8 @@ pkgdesc='A simple screen locker for X'
arch=('x86_64')
url="https://tools.suckless.org/$_pkgname"
license=('MIT')
-depends=('libxext' 'libxrandr')
-makedepends=('ncurses' 'git')
+depends=('libxrandr')
+makedepends=('git')
provides=("$_pkgname")
conflicts=("$_pkgname")
source=("git+https://git.jxir.de/$_pkgname")
diff --git a/st/PKGBUILD b/st/PKGBUILD
index 021f66a..9dcca2e 100644
--- a/st/PKGBUILD
+++ b/st/PKGBUILD
@@ -8,8 +8,8 @@ pkgdesc='A simple virtual terminal emulator for X'
arch=('x86_64')
url="https://$_pkgname.suckless.org"
license=('MIT')
-depends=('libxext' 'libxft')
-makedepends=('ncurses' 'git')
+depends=('libxft')
+makedepends=('git' 'ncurses')
provides=("$_pkgname")
conflicts=("$_pkgname")
source=("git+https://git.jxir.de/$_pkgname")
diff --git a/vifm/PKGBUILD b/vifm/PKGBUILD
index f4006a3..c570a63 100644
--- a/vifm/PKGBUILD
+++ b/vifm/PKGBUILD
@@ -8,7 +8,7 @@ pkgdesc='A file manager with curses interface, which provides Vi[m]-like environ
arch=('x86_64')
url="https://vifm.info/"
license=('GPL')
-depends=('file' 'ncurses')
+depends=('file' 'bash')
optdepends=('perl: vifm-convert-dircolors')
provides=("$_pkgname")
conflicts=("$_pkgname")