summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Gassner <justin.gassner@mailbox.org>2019-11-17 19:34:31 +0100
committerJustin Gassner <justin.gassner@mailbox.org>2019-11-17 19:34:31 +0100
commitb3fdc2ed1c335090268dc97842366e690d214dba (patch)
tree8bc5d31b577b83a093a275e74939f085ee4a2388
parent227cc9b87980ee423d7cfc561f2b7689ed1d88bf (diff)
downloadpackages-b3fdc2ed1c335090268dc97842366e690d214dba.tar.zst
Add gnuplot
-rw-r--r--gnuplot/PKGBUILD56
1 files changed, 56 insertions, 0 deletions
diff --git a/gnuplot/PKGBUILD b/gnuplot/PKGBUILD
new file mode 100644
index 0000000..4bac52c
--- /dev/null
+++ b/gnuplot/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Justin Gassner <justin.gassner@mailbox.org>
+
+_pkgname=gnuplot
+pkgname=$_pkgname-jxir
+pkgver=5.2.7
+pkgrel=1
+pkgdesc='Plotting package which outputs to X11, PostScript, PNG, GIF, and others'
+arch=('x86_64')
+url='http://www.gnuplot.info'
+license=('custom')
+depends=('pango' 'lua')
+makedepends=('texinfo')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("https://downloads.sourceforge.net/sourceforge/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('97fe503ff3b2e356fe2ae32203fc7fd2cf9cef1f46b60fe46dc501a228b9f4ed')
+
+prepare() {
+ cd "$_pkgname-$pkgver"
+
+ # fix default source location; use the GDFONTPATH variable to modify at runtime
+ sed -i 's|/usr/X11R6/lib/X11/fonts/truetype|/usr/share/fonts/TTF|' src/variable.c
+
+ sed -i -e 's|/usr/X11R6/lib/X11/fonts/Type1|/usr/share/fonts/Type1|' \
+ -e 's|$(X11ROOT)/X11R6/lib/X11/fonts/Type1|$(X11ROOT)/usr/share/fonts/Type1|' \
+ src/variable.c
+}
+
+build() {
+ cd "$_pkgname-$pkgver"
+
+ ./configure \
+ --prefix=/usr \
+ --libexecdir=/usr/bin \
+ --disable-history-file \
+ --disable-wxwidgets \
+ --with-texdir=/usr/share/texmf-dist/tex/latex/gnuplot \
+ --with-gihdir=/usr/share/gnuplot \
+ --without-libcerf \
+ --without-latex \
+ --without-x \
+ --without-linux-vga \
+ --with-readline=gnu \
+ --without-gd \
+ --without-qt
+ make
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ make pkglibexecdir=/usr/bin DESTDIR="$pkgdir" install
+
+ install -Dm644 Copyright "$pkgdir/usr/share/licenses/$pkgname/Copyright"
+
+ rm -f "$pkgdir/usr/share/texmf-dist/ls-R"
+}