summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Gassner <justin.gassner@mailbox.org>2019-09-26 12:45:45 +0200
committerJustin Gassner <justin.gassner@mailbox.org>2019-09-26 12:45:45 +0200
commitfc8a7aa70497ba83b3e66aa3954e25e71372acea (patch)
tree2219e3b7fbd5568aab9e7acd8e0de20d43790236
parenta502db1b6c9d0b974daa9aab7636f57d8984ee2f (diff)
downloadpackages-fc8a7aa70497ba83b3e66aa3954e25e71372acea.tar.zst
Add redshift
-rw-r--r--redshift/PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/redshift/PKGBUILD b/redshift/PKGBUILD
new file mode 100644
index 0000000..5b299ed
--- /dev/null
+++ b/redshift/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Justin Gassner <justin.gassner@mailbox.org>
+
+_pkgname=redshift
+pkgname=$_pkgname-jxir
+pkgver=1.12
+pkgrel=2
+pkgdesc='Adjusts the color temperature of your screen according to your surroundings.'
+arch=('x86_64')
+url='https://jonls.dk/redshift/'
+license=('GPL3')
+depends=('libxcb')
+makedepends=('intltool')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("https://github.com/jonls/$_pkgname/releases/download/v$pkgver/$_pkgname-$pkgver.tar.xz")
+sha256sums=('d2f8c5300e3ce2a84fe6584d2f1483aa9eadc668ab1951b2c2b8a03ece3a22ba')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ ./configure \
+ --prefix=/usr \
+ --disable-nls \
+ --disable-drm \
+ --enable-randr \
+ --disable-vidmode \
+ --disable-geoclue2 \
+ --disable-gui \
+ --with-systemduserunitdir=/usr/lib/systemd/user
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}