summaryrefslogtreecommitdiffstats
path: root/alsa-utils/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'alsa-utils/PKGBUILD')
-rw-r--r--alsa-utils/PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/alsa-utils/PKGBUILD b/alsa-utils/PKGBUILD
new file mode 100644
index 0000000..2c9f34b
--- /dev/null
+++ b/alsa-utils/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Justin Gassner <justin.gassner@mailbox.org>
+
+_pkgname=alsa-utils
+pkgname=$_pkgname-jxir
+pkgver=1.2.1
+pkgrel=1
+pkgdesc="An alternative implementation of Linux sound support"
+arch=('x86_64')
+url="https://www.alsa-project.org"
+license=('GPL')
+depends=('alsa-lib' 'bash')
+makedepends=('xmlto' 'docbook-xsl' 'systemd')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("ftp://ftp.alsa-project.org/pub/utils/$_pkgname-$pkgver.tar.bz2")
+sha256sums=('0b110ba71ef41d3009db1bc4dcae0cf79efb99cb5426fa19d0312470560a2c0d')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ ./configure \
+ --prefix=/usr \
+ --sbindir=/usr/bin \
+ --disable-nls \
+ --disable-alsatest \
+ --disable-bat \
+ --disable-alsaconf \
+ --disable-alsaloop \
+ --with-udev-rules-dir=/usr/lib/udev/rules.d \
+ --with-systemdsystemunitdir=/usr/lib/systemd/system
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+
+ # dir where to save ALSA state
+ install -d "$pkgdir/var/lib/alsa"
+}