summaryrefslogtreecommitdiffstats
path: root/dwm/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'dwm/PKGBUILD')
-rw-r--r--dwm/PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/dwm/PKGBUILD b/dwm/PKGBUILD
index 996c3a7..24a3731 100644
--- a/dwm/PKGBUILD
+++ b/dwm/PKGBUILD
@@ -25,6 +25,9 @@ prepare() {
for branch in noborder pertag fancybar config; do
git merge --no-edit origin/$branch
done
+ echo "CPPFLAGS+=${CPPFLAGS}" >> config.mk
+ echo "CFLAGS+=${CFLAGS}" >> config.mk
+ echo "LDFLAGS+=${LDFLAGS}" >> config.mk
mv config.def.h config.h
}
@@ -36,6 +39,6 @@ build() {
package() {
cd "$_pkgname"
make PREFIX=/usr DESTDIR="$pkgdir" install
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
- install -Dm644 README "$pkgdir/usr/share/doc/$_pkgname/README"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+ install -Dm644 README -t "$pkgdir/usr/share/doc/$_pkgname"
}