summaryrefslogtreecommitdiffstats
path: root/gnuplot/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'gnuplot/PKGBUILD')
-rw-r--r--gnuplot/PKGBUILD56
1 files changed, 0 insertions, 56 deletions
diff --git a/gnuplot/PKGBUILD b/gnuplot/PKGBUILD
deleted file mode 100644
index 4bac52c..0000000
--- a/gnuplot/PKGBUILD
+++ /dev/null
@@ -1,56 +0,0 @@
-# Maintainer: Justin Gassner <justin.gassner@mailbox.org>
-
-_pkgname=gnuplot
-pkgname=$_pkgname-jxir
-pkgver=5.2.7
-pkgrel=1
-pkgdesc='Plotting package which outputs to X11, PostScript, PNG, GIF, and others'
-arch=('x86_64')
-url='http://www.gnuplot.info'
-license=('custom')
-depends=('pango' 'lua')
-makedepends=('texinfo')
-provides=("$_pkgname")
-conflicts=("$_pkgname")
-source=("https://downloads.sourceforge.net/sourceforge/$_pkgname/$_pkgname-$pkgver.tar.gz")
-sha256sums=('97fe503ff3b2e356fe2ae32203fc7fd2cf9cef1f46b60fe46dc501a228b9f4ed')
-
-prepare() {
- cd "$_pkgname-$pkgver"
-
- # fix default source location; use the GDFONTPATH variable to modify at runtime
- sed -i 's|/usr/X11R6/lib/X11/fonts/truetype|/usr/share/fonts/TTF|' src/variable.c
-
- sed -i -e 's|/usr/X11R6/lib/X11/fonts/Type1|/usr/share/fonts/Type1|' \
- -e 's|$(X11ROOT)/X11R6/lib/X11/fonts/Type1|$(X11ROOT)/usr/share/fonts/Type1|' \
- src/variable.c
-}
-
-build() {
- cd "$_pkgname-$pkgver"
-
- ./configure \
- --prefix=/usr \
- --libexecdir=/usr/bin \
- --disable-history-file \
- --disable-wxwidgets \
- --with-texdir=/usr/share/texmf-dist/tex/latex/gnuplot \
- --with-gihdir=/usr/share/gnuplot \
- --without-libcerf \
- --without-latex \
- --without-x \
- --without-linux-vga \
- --with-readline=gnu \
- --without-gd \
- --without-qt
- make
-}
-
-package() {
- cd "$_pkgname-$pkgver"
- make pkglibexecdir=/usr/bin DESTDIR="$pkgdir" install
-
- install -Dm644 Copyright "$pkgdir/usr/share/licenses/$pkgname/Copyright"
-
- rm -f "$pkgdir/usr/share/texmf-dist/ls-R"
-}