summaryrefslogtreecommitdiffstats
path: root/mpop
diff options
context:
space:
mode:
Diffstat (limited to 'mpop')
-rw-r--r--mpop/PKGBUILD27
-rw-r--r--mpop/change-configuration-file-location.patch25
2 files changed, 12 insertions, 40 deletions
diff --git a/mpop/PKGBUILD b/mpop/PKGBUILD
index de42abe..fcb49d5 100644
--- a/mpop/PKGBUILD
+++ b/mpop/PKGBUILD
@@ -2,30 +2,27 @@
_pkgname=mpop
pkgname=$_pkgname-jxir
-pkgver=1.2.6
+pkgver=1.2.8.5.g29131be
pkgrel=1
pkgdesc='A small, fast POP3 client'
arch=('x86_64')
-url="http://$_pkgname.sourceforge.net"
+url="https://marlam.de/$_pkgname/"
license=('GPL3')
depends=('gsasl')
makedepends=('texlive-plainextra')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("http://downloads.sourceforge.net/$_pkgname/$_pkgname-$pkgver.tar.xz"{,.sig}
- 'change-configuration-file-location.patch')
-sha256sums=('9fec7a9dd08fc0f04bf6178bc651b036d1fe0e46903146f38a8d182887e9315c'
- 'SKIP'
- 'ca36ec82129c14a1f69d51beb89fcd2a6a79ec4d2eac7f4248207c9aaf2229a4')
-validpgpkeys=('2F788CDEF4181652720EF132F4926138953E5294') # Martin Lambers
+source=("git+https://gitlab.marlam.de/marlam/$_pkgname.git")
+sha256sums=('SKIP')
-prepare() {
- cd "$srcdir/$_pkgname-$pkgver"
- patch -p1 -i "$srcdir/change-configuration-file-location.patch"
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long | sed "s/$_pkgname-//;s/-/./g"
}
build() {
- cd "$srcdir/$_pkgname-$pkgver"
+ cd "$srcdir/$_pkgname"
+ autoreconf -i
./configure \
--prefix=/usr \
--disable-nls \
@@ -36,9 +33,9 @@ build() {
}
package() {
- cd "$srcdir/$_pkgname-$pkgver"
+ cd "$srcdir/$_pkgname"
make DESTDIR="$pkgdir" install
make DESTDIR="$pkgdir" -C doc install-pdf
- install -D -m644 doc/*.example "$pkgdir/usr/share/doc/$_pkgname/"
- install -D -m644 "scripts/vim/$_pkgname.vim" "$pkgdir/usr/share/nvim/runtime/syntax/$_pkgname.vim"
+ install -Dm644 doc/*.example "$pkgdir/usr/share/doc/$_pkgname/"
+ install -Dm644 "scripts/vim/$_pkgname.vim" "$pkgdir/usr/share/nvim/runtime/syntax/$_pkgname.vim"
}
diff --git a/mpop/change-configuration-file-location.patch b/mpop/change-configuration-file-location.patch
deleted file mode 100644
index 4deffb5..0000000
--- a/mpop/change-configuration-file-location.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From d1127c5cef14cb25fcae305071d83d5f89f810d8 Mon Sep 17 00:00:00 2001
-From: Justin Gassner <justin.gassner@web.de>
-Date: Wed, 18 May 2016 22:46:31 +0200
-Subject: [PATCH] Change configuration file location
-
----
- src/mpop.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/mpop.c b/src/mpop.c
-index 2770cf9..60b155f 100644
---- a/src/mpop.c
-+++ b/src/mpop.c
-@@ -97,7 +97,7 @@ extern int optind;
- #define USERNETRCFILE "_netrc"
- #define SYSNETRCFILE "netrc"
- #else /* UNIX */
--#define CONFFILE ".mpoprc"
-+#define CONFFILE ".config/mpop"
- #define UIDLSFILE ".mpop_uidls/%U_at_%H"
- #define USERNETRCFILE ".netrc"
- #define SYSNETRCFILE "netrc"
---
-2.8.2
-