summaryrefslogtreecommitdiffstats
path: root/msmtp/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'msmtp/PKGBUILD')
-rw-r--r--msmtp/PKGBUILD25
1 files changed, 11 insertions, 14 deletions
diff --git a/msmtp/PKGBUILD b/msmtp/PKGBUILD
index 9c7cdcb..a666cf6 100644
--- a/msmtp/PKGBUILD
+++ b/msmtp/PKGBUILD
@@ -2,30 +2,27 @@
_pkgname=msmtp
pkgname=$_pkgname-jxir
-pkgver=1.6.6
+pkgver=1.6.8.5.g09a1cb4
pkgrel=1
-pkgdesc='A small, fast SMTP client'
+pkgdesc='A small, fast POP3 client'
arch=('x86_64')
-url="http://$_pkgname.sourceforge.net"
+url="https://marlam.de/$_pkgname/"
license=('GPL3')
depends=('gsasl')
makedepends=('texlive-plainextra')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("http://downloads.sourceforge.net/$_pkgname/$_pkgname-$pkgver.tar.xz"{,.sig}
- 'change-configuration-file-location.patch')
-sha256sums=('da15db1f62bd0201fce5310adb89c86188be91cd745b7cb3b62b81a501e7fb5e'
- 'SKIP'
- '46bb7505e7a2298846cb03ba4cacc4b1cabd09bb425715a02d2c3ec1a7780ad4')
-validpgpkeys=('2F788CDEF4181652720EF132F4926138953E5294') # Martin Lambers
+source=("git+https://gitlab.marlam.de/marlam/$_pkgname.git")
+sha256sums=('SKIP')
-prepare() {
- cd "$srcdir/$_pkgname-$pkgver"
- patch -p1 -i "$srcdir/change-configuration-file-location.patch"
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long | sed "s/$_pkgname-//;s/-/./g"
}
build() {
- cd "$srcdir/$_pkgname-$pkgver"
+ cd "$srcdir/$_pkgname"
+ autoreconf -i
./configure \
--prefix=/usr \
--disable-nls \
@@ -36,7 +33,7 @@ build() {
}
package() {
- cd "$srcdir/$_pkgname-$pkgver"
+ cd "$srcdir/$_pkgname"
make DESTDIR="$pkgdir" install
make DESTDIR="$pkgdir" -C doc install-pdf
install -Dm644 doc/*.example "$pkgdir/usr/share/doc/$_pkgname/"