summaryrefslogtreecommitdiffstats
path: root/neovim/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'neovim/PKGBUILD')
-rw-r--r--neovim/PKGBUILD64
1 files changed, 0 insertions, 64 deletions
diff --git a/neovim/PKGBUILD b/neovim/PKGBUILD
deleted file mode 100644
index a8fb82b..0000000
--- a/neovim/PKGBUILD
+++ /dev/null
@@ -1,64 +0,0 @@
-# Maintainer: Justin Gassner <justin.gassner@mailbox.org>
-
-_pkgname=neovim
-pkgname=$_pkgname-jxir
-pkgver=0.4.0.r366.g97f122200
-pkgrel=1
-pkgdesc='Fork of Vim aiming to improve user experience, plugins, and GUIs'
-arch=('x86_64')
-url='https://neovim.io'
-license=('custom:neovim')
-depends=('bash' 'libluv' 'libtermkey' 'libvterm' 'msgpack-c' 'libutf8proc')
-makedepends=('cmake' 'git' 'gperf' 'lua51-lpeg' 'lua51-mpack')
-optdepends=('python2-neovim: for Python 2 plugin support (see :help python)'
- 'python-neovim: for Python 3 plugin support (see :help python)'
- 'xclip: for clipboard support (or xsel) (see :help clipboard)'
- 'xsel: for clipboard support (or xclip) (see :help clipboard)')
-provides=("$_pkgname")
-conflicts=("$_pkgname")
-source=("git+https://github.com/$_pkgname/$_pkgname.git")
-sha256sums=('SKIP')
-
-pkgver() {
- cd "$_pkgname"
- git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
-build() {
- mkdir -p "$_pkgname/build"
- cd "$_pkgname/build"
- cmake -G 'Unix Makefiles' \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DENABLE_LIBINTL=OFF \
- ..
- make
-}
-
-check() {
- cd "$_pkgname/build"
- ./bin/nvim --version
- ./bin/nvim --headless -u NONE -i NONE -c ':quit'
-}
-
-package() {
- cd "$_pkgname/build"
- make DESTDIR="${pkgdir}" install
- cd "$srcdir/$_pkgname"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-
- rm -rf "$pkgdir/usr/share/applications/"
- rm -rf "$pkgdir/usr/share/nvim/runtime/"{autoload/gzip.vim,doc/pi_gzip.txt,plugin/gzip.vim}
- rm -rf "$pkgdir/usr/share/nvim/runtime/"{autoload/netrw.vim,autoload/netrwFileHandlers.vim,autoload/netrwSettings.vim,autoload/netrw_gitignore.vim,doc/pi_netrw.txt,plugin/netrwPlugin.vim,syntax/netrw.vim}
- rm -rf "$pkgdir/usr/share/nvim/runtime/"{autoload/tar.vim,doc/pi_tar.txt,plugin/tarPlugin.vim}
- rm -rf "$pkgdir/usr/share/nvim/runtime/"{autoload/tohtml.vim,plugin/tohtml.vim,syntax/2html.vim}
- rm -rf "$pkgdir/usr/share/nvim/runtime/"{autoload/tutor.vim,doc/pi_tutor.txt,ftplugin/tutor.vim,plugin/tutor.vim,syntax/tutor.vim,tutor/}
- rm -rf "$pkgdir/usr/share/nvim/runtime/"{autoload/zip.vim,doc/pi_zip.txt,plugin/zipPlugin.vim}
- rm -rf "$pkgdir/usr/share/nvim/runtime/"{doc/pi_matchit.txt,macros/matchit.vim,plugin/matchit.vim}
- rm -rf "$pkgdir/usr/share/nvim/runtime/keymap/"
- rm -rf "$pkgdir/usr/share/nvim/runtime/pack/dist/opt/"
- rm -rf "$pkgdir/usr/share/nvim/runtime/plugin/matchparen.vim"
- rm -rf "$pkgdir/usr/share/pixmaps/"
-
- ln -s nvim "$pkgdir/usr/bin/vim"
-}