summaryrefslogtreecommitdiffstats
path: root/slock/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'slock/PKGBUILD')
-rw-r--r--slock/PKGBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/slock/PKGBUILD b/slock/PKGBUILD
index 7260e69..7ab9a69 100644
--- a/slock/PKGBUILD
+++ b/slock/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=slock
pkgname=$_pkgname-jxir
-pkgver=1.4.r6.g2aa4369
+pkgver=1.4.r7.gdb7c62e
pkgrel=1
pkgdesc='A simple screen locker for X'
arch=('x86_64')
@@ -25,19 +25,16 @@ prepare() {
for branch in config; do
git merge --no-edit origin/$branch
done
- echo "CPPFLAGS+=${CPPFLAGS}" >> config.mk
- echo "CFLAGS+=${CFLAGS}" >> config.mk
- echo "LDFLAGS+=${LDFLAGS}" >> config.mk
}
build() {
cd "$_pkgname"
- make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11
+ make
}
package() {
cd "$_pkgname"
- make PREFIX=/usr DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" install
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
install -Dm644 README -t "$pkgdir/usr/share/doc/$_pkgname"
}