summaryrefslogtreecommitdiffstats
path: root/st/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'st/PKGBUILD')
-rw-r--r--st/PKGBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/st/PKGBUILD b/st/PKGBUILD
index a4c6840..b51766b 100644
--- a/st/PKGBUILD
+++ b/st/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=st
pkgname=$_pkgname-jxir
-pkgver=0.8.2.r24.g7e5b23e
+pkgver=0.8.4.r10.ge290ec4
pkgrel=1
pkgdesc='A simple virtual terminal emulator for X'
arch=('x86_64')
@@ -25,19 +25,16 @@ prepare() {
for branch in no-bold-colors solarized-dark scrollback config; do
git merge --no-edit origin/$branch
done
- echo "CPPFLAGS+=${CPPFLAGS}" >> config.mk
- echo "CFLAGS+=${CFLAGS}" >> config.mk
- echo "LDFLAGS+=${LDFLAGS}" >> config.mk
}
build() {
cd "$_pkgname"
- make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11
+ make
}
package() {
cd "$_pkgname"
- make PREFIX=/usr DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" install
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
install -Dm644 README -t "$pkgdir/usr/share/doc/$_pkgname"
}