aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJay Berkenbilt <ejb@ql.org>2023-12-16 17:12:52 +0100
committerJay Berkenbilt <ejb@ql.org>2023-12-16 17:38:00 +0100
commit762f232146f3edc234c898b48e9daacf72ee9577 (patch)
tree60a6f31f14b9b125561c5fa3c15a5171c9afeece /CMakeLists.txt
parentdb4ec7a9db7a0d87d459d7dc80f9a2afb4cbeadb (diff)
downloadqpdf-762f232146f3edc234c898b48e9daacf72ee9577.tar.zst
Add CI build for next C++ version
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index aafca4f8..707db439 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -106,6 +106,7 @@ option(INSTALL_CMAKE_PACKAGE "Install cmake package files" ON)
option(INSTALL_EXAMPLES "Install example files" ON)
option(FUTURE "Include ABI-breaking changes CONSIDERED for the next major release" OFF)
+option(CXX_NEXT "Build with next C++ standard version" OFF)
# *** END OPTIONS ***
@@ -166,7 +167,11 @@ Please build with cmake in a subdirectory, e.g.
Please remove CMakeCache.txt and the CMakeFiles directories.")
endif()
-set(CMAKE_CXX_STANDARD 17)
+if(CXX_NEXT)
+ set(CMAKE_CXX_STANDARD 20)
+else()
+ set(CMAKE_CXX_STANDARD 17)
+endif()
set(CMAKE_CXX_EXTENSIONS OFF)
set(CMAKE_CXX_STANDARD_REQUIRED ON)
set(CMAKE_C_VISIBILITY_PRESET hidden)