aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJay Berkenbilt <ejb@ql.org>2022-09-14 13:38:15 +0200
committerJay Berkenbilt <ejb@ql.org>2022-09-14 13:41:13 +0200
commitfaac493a5dcbe913ccc950b92b9f8c1e8492b7ef (patch)
tree980fba10b0cc2157e2f2d0f318aedfe1516a462d /CMakeLists.txt
parent5796475a5e0df5d2e30e8351ab6a09dcebbd1585 (diff)
downloadqpdf-faac493a5dcbe913ccc950b92b9f8c1e8492b7ef.tar.zst
Force project includes before system includes (fixes #763)
From time to time, someone has a problem because their build is grabbing an old version of qpdf header files that are installed somewhere on their system. I am hoping this will put an end to that.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1c4a023f..46fb4367 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -111,6 +111,7 @@ if(NOT (BUILD_STATIC_LIBS OR BUILD_SHARED_LIBS))
FATAL_ERROR "At least one of static or shared libraries must be built")
endif()
+set(CMAKE_INCLUDE_DIRECTORIES_PROJECT_BEFORE ON)
add_compile_definitions($<$<COMPILE_LANGUAGE:CXX>:POINTERHOLDER_TRANSITION=4>)
if(ENABLE_QTC)