aboutsummaryrefslogtreecommitdiffstats
path: root/libqpdf/CMakeLists.txt
diff options
context:
space:
mode:
authorJay Berkenbilt <ejb@ql.org>2023-09-03 15:35:28 +0200
committerJay Berkenbilt <ejb@ql.org>2023-09-03 15:36:13 +0200
commit87765bace9be7d8105b3d148dd389a612299275b (patch)
tree8eab43ac1c2d19e59afa642731d03936b224f039 /libqpdf/CMakeLists.txt
parent2b4dcb33aa3cc130241894df78e2b67bbe5c99b8 (diff)
downloadqpdf-87765bace9be7d8105b3d148dd389a612299275b.tar.zst
Move random number device check to runtime (fixes #1022)
Having it at compile time breaks cross-compilation and isn't really right anyway.
Diffstat (limited to 'libqpdf/CMakeLists.txt')
-rw-r--r--libqpdf/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/libqpdf/CMakeLists.txt b/libqpdf/CMakeLists.txt
index fbe85cf9..c6a122c6 100644
--- a/libqpdf/CMakeLists.txt
+++ b/libqpdf/CMakeLists.txt
@@ -320,8 +320,6 @@ check_symbol_exists(fseeko "stdio.h" HAVE_FSEEKO)
check_symbol_exists(fseeko64 "stdio.h" HAVE_FSEEKO64)
check_symbol_exists(localtime_r "time.h" HAVE_LOCALTIME_R)
check_symbol_exists(random "stdlib.h" HAVE_RANDOM)
-find_file(RANDOM_DEVICE
- "urandom" "arandom" "arandom" PATHS "/dev" NO_DEFAULT_PATH)
check_c_source_compiles(
"#include <time.h>