aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1a474011..4dd3e329 100644
--- a/configure.ac
+++ b/configure.ac
@@ -501,6 +501,17 @@ AC_ARG_ENABLE(validate-doc,
fi],
[VALIDATE_DOC=$doc_default])
+AC_SUBST(OSS_FUZZ)
+AC_ARG_ENABLE(oss-fuzz,
+ AS_HELP_STRING([--enable-doc-maintenance],
+ [if set, build static fuzzers for oss-fuzz]),
+ [if test "$enableval" = "yes"; then
+ OSS_FUZZ=1;
+ else
+ OSS_FUZZ=0;
+ fi],
+ [OSS_FUZZ=0])
+
if test "$VALIDATE_DOC" = "1"; then
if test "$XMLLINT" = ""; then
MISSING_XMLLINT=1