aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c1cf187c..21481311 100644
--- a/configure.ac
+++ b/configure.ac
@@ -212,6 +212,17 @@ AC_ARG_ENABLE(test-compare-images,
fi],
[SKIP_TEST_COMPARE_IMAGES=0])
+AC_SUBST(SHOW_FAILED_TEST_OUTPUT)
+AC_ARG_ENABLE(show-failed-test-output,
+ AS_HELP_STRING([--enable-show-failed-test-output],
+ [if specified, write failed test output to the console; useful for building on build servers where you can't easily open the test output files]),
+ [if test "$enableval" = "no"; then
+ SHOW_FAILED_TEST_OUTPUT=0
+ else
+ SHOW_FAILED_TEST_OUTPUT=1
+ fi],
+ [SHOW_FAILED_TEST_OUTPUT=0])
+
AC_ARG_WITH(docbook-xsl,
AS_HELP_STRING([--with-docbook-xsl=DIR],
[location of docbook 4.x xml stylesheets]),