aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bd2ee15a..136e51b7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -61,6 +61,23 @@ AC_SUBST(LT_AGE)
LT_SONAME=$(expr $LT_CURRENT - $LT_AGE)
AC_SUBST(LT_SONAME)
+AC_MSG_CHECKING(for whether to use -rpath)
+AC_ARG_ENABLE(rpath,
+ AS_HELP_STRING([--enable-rpath],
+ [whether to pass -rpath to the linker when building libraries]),
+ [if test "$enableval" = "yes"; then
+ qpdf_USE_RPATH=1;
+ else
+ qpdf_USE_RPATH=0;
+ fi], [qpdf_USE_RPATH=1])
+if test "$qpdf_USE_RPATH" = "1"; then
+ AC_MSG_RESULT(yes)
+ RPATH='-rpath $(libdir)'
+else
+ AC_MSG_RESULT(no)
+fi
+AC_SUBST(RPATH)
+
AC_MSG_CHECKING(for -fvisibility=hidden)
try_flags=-fvisibility=hidden
oCXXFLAGS=$CXXFLAGS