aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 16 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8f87797c..1ee57347 100644
--- a/configure.ac
+++ b/configure.ac
@@ -31,6 +31,21 @@ else
AC_MSG_RESULT(yes)
fi
+WINDOWS_WORDSIZE=
+AC_SUBST(WINDOWS_WORDSIZE)
+AC_ARG_WITH(windows-wordsize,
+ AS_HELP_STRING([--with-windows-wordsize={32,64}],
+ [Windows only: whether this is a 32-bit or 64-bit build; required if external-libs are enabled]),
+ [WINDOWS_WORDSIZE=$withval],
+ [WINDOWS_WORDSIZE=none])
+if test "$USE_EXTERNAL_LIBS" = "1"; then
+ AC_MSG_CHECKING(for windows wordsize)
+ AC_MSG_RESULT($WINDOWS_WORDSIZE)
+ if ! test "$WINDOWS_WORDSIZE" = "32" -o "$WINDOWS_WORDSIZE" = "64"; then
+ AC_MSG_ERROR(Windows wordsize of 32 or 64 must be specified if external libs are being used.)
+ fi
+fi
+
if test "$BUILD_INTERNAL_LIBS" = "0"; then
AC_CHECK_HEADER(zlib.h,,[MISSING_ZLIB_H=1; MISSING_ANY=1])
AC_SEARCH_LIBS(deflate,z zlib,,[MISSING_ZLIB=1; MISSING_ANY=1])
@@ -378,7 +393,7 @@ if test "$USE_EXTERNAL_LIBS" = "1"; then
# the user can run this and then edit autoconf.mk if they have too
# much trouble getting it to work with a different compiler.
CPPFLAGS="$CPPFLAGS -Iexternal-libs/include"
- LDFLAGS="$LDFLAGS -Lexternal-libs/lib-$BUILDRULES"
+ LDFLAGS="$LDFLAGS -Lexternal-libs/lib-$BUILDRULES$WINDOWS_WORDSIZE"
LIBS="$LIBS -lz -lpcre"
fi