aboutsummaryrefslogtreecommitdiffstats
path: root/include/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'include/CMakeLists.txt')
-rw-r--r--include/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/include/CMakeLists.txt b/include/CMakeLists.txt
new file mode 100644
index 00000000..3110ba9c
--- /dev/null
+++ b/include/CMakeLists.txt
@@ -0,0 +1,12 @@
+set(qpdf_INCLUDE ${CMAKE_CURRENT_SOURCE_DIR} PARENT_SCOPE)
+
+# While globs are not considered best practice, it makes sense for
+# installation o header files. When compiling, you specify an entire
+# directory, so not doing the same at installation time creates a high
+# risk that forgetting to explicitly add a header to an installation
+# list would not be detected in CI or at any time until an end user
+# tries to build code.
+install(DIRECTORY qpdf
+ TYPE INCLUDE
+ COMPONENT ${COMPONENT_DEV}
+ FILES_MATCHING PATTERN "*.h" PATTERN "*.hh")