aboutsummaryrefslogtreecommitdiffstats
path: root/libtests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libtests/CMakeLists.txt')
-rw-r--r--libtests/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/libtests/CMakeLists.txt b/libtests/CMakeLists.txt
index 196cd3eb..62ba390e 100644
--- a/libtests/CMakeLists.txt
+++ b/libtests/CMakeLists.txt
@@ -33,10 +33,18 @@ set(TEST_PROGRAMS
runlength
sha2
sparse_array)
+set(TEST_C_PROGRAMS
+ logger_c)
+
foreach(PROG ${TEST_PROGRAMS})
add_executable(${PROG} ${PROG}.cc)
target_link_libraries(${PROG} libqpdf_object)
endforeach()
+foreach(PROG ${TEST_C_PROGRAMS})
+ add_executable(${PROG} ${PROG}.c)
+ target_link_libraries(${PROG} libqpdf_object)
+ set_property(TARGET ${PROG} PROPERTY LINKER_LANGUAGE CXX)
+endforeach()
# Since libtests link with the object library and don't use the DLL,
# we don't need to (and shouldn't) add the libqpdf target directory to