summaryrefslogtreecommitdiffstats
path: root/neovim/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'neovim/PKGBUILD')
-rw-r--r--neovim/PKGBUILD39
1 files changed, 21 insertions, 18 deletions
diff --git a/neovim/PKGBUILD b/neovim/PKGBUILD
index edfc778..50a5bb0 100644
--- a/neovim/PKGBUILD
+++ b/neovim/PKGBUILD
@@ -2,19 +2,18 @@
_pkgname=neovim
pkgname=$_pkgname-jxir
-pkgver=0.2.0.r922.g01487d438
+pkgver=0.3.4.r188.g6e6bc3b6c
pkgrel=1
pkgdesc='Fork of Vim aiming to improve user experience, plugins, and GUIs'
arch=('x86_64')
url='https://neovim.io'
license=('custom:neovim')
-depends=('jemalloc' 'libtermkey' 'libuv' 'libvterm' 'luajit' 'msgpack-c' 'unibilium')
-makedepends=('cmake' 'git' 'gperf' 'lua51-lpeg' 'lua51-mpack')
-optdepends=('python2-neovim: for Python 2 plugin support (see :help provider-python)'
- 'python-neovim: for Python 3 plugin support (see :help provider-python)'
- 'ruby-neovim: for Ruby plugin support (see :help provider-ruby)'
- 'xclip: for clipboard support (or xsel) (see :help provider-clipboard)'
- 'xsel: for clipboard support (or xclip) (see :help provider-clipboard)')
+depends=('libtermkey' 'libuv' 'libvterm' 'luajit' 'msgpack-c' 'unibilium')
+makedepends=('cmake' 'git' 'gperf' 'lua51-lpeg' 'lua51-mpack' 'ninja')
+optdepends=('python2-neovim: for Python 2 plugin support (see :help python)'
+ 'python-neovim: for Python 3 plugin support (see :help python)'
+ 'xclip: for clipboard support (or xsel) (see :help clipboard)'
+ 'xsel: for clipboard support (or xclip) (see :help clipboard)')
provides=("$_pkgname")
conflicts=("$_pkgname")
source=("git+https://github.com/$_pkgname/$_pkgname.git")
@@ -26,25 +25,29 @@ pkgver() {
}
build() {
- mkdir -p "$_pkgname/build"
- cd "$_pkgname/build"
- cmake -G 'Unix Makefiles' \
+ cd "$srcdir"
+ cmake -Hneovim -Bbuild -GNinja \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DENABLE_JEMALLOC=ON \
- ..
- make
+ -DENABLE_LIBINTL=OFF
+ cmake --build build
}
check() {
- cd "$_pkgname/build"
+ cd "$srcdir/build"
./bin/nvim --version
./bin/nvim --headless -u NONE -i NONE -c ':quit'
}
package() {
- cd "$_pkgname/build"
- make DESTDIR="$pkgdir" install
- install -Dm644 ../LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+ cd "$srcdir/build"
+ DESTDIR="$pkgdir" cmake --build . --target install
+ cd "$srcdir/$_pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+ #rm -rf "$pkgdir/usr/share/applications/"
+ #rm -rf "$pkgdir/usr/share/pixmaps/"
+ #rm -rf "$pkgdir/usr/share/nvim/runtime/"{autoload/tutor.vim,doc/pi_tutor.txt,plugin/tutor.vim,syntax/tutor.vim,tutor/}
+ #rm -rf "$pkgdir/usr/share/nvim/runtime/"{doc/pi_matchit.txt,macros/matchit.vim,plugin/matchit.vim}
+ #rm "$pkgdir/usr/share/nvim/runtime/plugin/"{gzip,matchparen,netrwPlugin,rplugin,spellfile,tarPlugin,tohtml,zipPlugin}.vim
ln -s nvim "$pkgdir/usr/bin/vim"
}