summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Gassner <justin.gassner@web.de>2019-01-26 00:59:17 +0100
committerJustin Gassner <justin.gassner@web.de>2019-01-26 00:59:17 +0100
commit2917fca392684c0275f9ac58362ff30215794fee (patch)
tree25305e4b1d4734362489031e2b13a344aaf9ad20
parent0a77c9c329c43752ec8f87c8e38c10744cefe771 (diff)
downloadpackages-2917fca392684c0275f9ac58362ff30215794fee.tar.zst
update
-rw-r--r--ffmpeg/PKGBUILD23
-rw-r--r--mpop/PKGBUILD2
-rw-r--r--msmtp/PKGBUILD2
-rw-r--r--mutt/PKGBUILD4
-rw-r--r--neovim/PKGBUILD39
-rw-r--r--vifm/PKGBUILD2
6 files changed, 38 insertions, 34 deletions
diff --git a/ffmpeg/PKGBUILD b/ffmpeg/PKGBUILD
index 1e73df5..bc67283 100644
--- a/ffmpeg/PKGBUILD
+++ b/ffmpeg/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=ffmpeg
pkgname=$_pkgname-jxir
-pkgver=3.3.4
+pkgver=4.1
pkgrel=1
epoch=1
pkgdesc='Complete solution to record, convert and stream audio and video'
@@ -10,13 +10,13 @@ arch=('x86_64')
url='https://ffmpeg.org/'
license=('GPL3')
depends=('alsa-lib' 'bzip2' 'fontconfig' 'libass' 'zlib')
-makedepends=('yasm')
+makedepends=('git' 'nasm')
provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
- 'libavutil.so' 'libpostproc.so' 'libswresample.so'
- 'libswscale.so' 'ffmpeg')
+ 'libavutil.so' 'libpostproc.so' 'libswresample.so' 'libswscale.so'
+ 'ffmpeg')
conflicts=('ffmpeg')
source=("http://ffmpeg.org/releases/$_pkgname-$pkgver.tar.xz"{,.asc})
-sha256sums=('98b97e1b908dfeb6aeb6d407e5a5eacdfc253a40c2d195f5867ed2d1d46ea957'
+sha256sums=('a38ec4d026efb58506a99ad5cd23d5a9793b4bf415f2c4c2e9c1bb444acd1994'
'SKIP')
validpgpkeys=('FCF986EA15E6E293A5644F10B4322F04D67658D8')
@@ -31,15 +31,16 @@ build() {
--disable-runtime-cpudetect \
--disable-swscale-alpha \
--disable-ffplay \
- --disable-ffserver \
--disable-doc \
--disable-network \
--disable-everything \
- --enable-encoder=libvorbis \
- --enable-decoder=aac,h264,libvorbis \
- --enable-muxer=mp4,ogg \
- --enable-demuxer=aac,ass,h264,matroska,mov,ogg \
- --enable-parser=aac,h264,vorbis \
+ --enable-rdft \
+ --enable-decoder=aac,h264,opus \
+ --enable-hwaccel=h264_vaapi,vp9_vaapi \
+ --enable-muxer=mp4,matroska,webm \
+ --enable-demuxer=aac,ass,h264,matroska,mov \
+ --enable-parser=aac,h264,opus,vp9 \
+ --enable-bsf=vp9_superframe \
--enable-protocol=file \
--enable-libass \
--enable-libfontconfig \
diff --git a/mpop/PKGBUILD b/mpop/PKGBUILD
index 09d79f0..3646ec9 100644
--- a/mpop/PKGBUILD
+++ b/mpop/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=mpop
pkgname=$_pkgname-jxir
-pkgver=1.4.1.12.ga856f51
+pkgver=1.4.2.1.g52c8e3c
pkgrel=1
pkgdesc='A small, fast POP3 client'
arch=('x86_64')
diff --git a/msmtp/PKGBUILD b/msmtp/PKGBUILD
index 20c807d..2e0df1b 100644
--- a/msmtp/PKGBUILD
+++ b/msmtp/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=msmtp
pkgname=$_pkgname-jxir
-pkgver=1.8.1.12.g1a1f73e
+pkgver=1.8.2.1.g9f99487
pkgrel=1
pkgdesc='A small, fast POP3 client'
arch=('x86_64')
diff --git a/mutt/PKGBUILD b/mutt/PKGBUILD
index 5e61d85..d8bb2ad 100644
--- a/mutt/PKGBUILD
+++ b/mutt/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=mutt
pkgname=$_pkgname-jxir
-pkgver=1.11.1
+pkgver=1.11.2
pkgrel=1
pkgdesc='Small but very powerful text-based mail client'
arch=('x86_64')
@@ -10,7 +10,7 @@ url='http://www.mutt.org'
license=('GPL')
depends=('gpgme' 'libidn' 'ncurses')
source=("http://ftp.mutt.org/pub/mutt/$_pkgname-$pkgver.tar.gz"{,.asc})
-sha256sums=('705141013662e53b78e49ed545360281f30a09ddda908f4de733277a60b1db05'
+sha256sums=('da5cd4c39f228914d3933d8cf3a017c8271fdd9b9d81c6e4fc42ad22e1a28723'
'SKIP')
validpgpkeys=('8975A9B33AA37910385C5308ADEF768480316BDA') # Kevin McCarthy
diff --git a/neovim/PKGBUILD b/neovim/PKGBUILD
index edfc778..50a5bb0 100644
--- a/neovim/PKGBUILD
+++ b/neovim/PKGBUILD
@@ -2,19 +2,18 @@
_pkgname=neovim
pkgname=$_pkgname-jxir
-pkgver=0.2.0.r922.g01487d438
+pkgver=0.3.4.r188.g6e6bc3b6c
pkgrel=1
pkgdesc='Fork of Vim aiming to improve user experience, plugins, and GUIs'
arch=('x86_64')
url='https://neovim.io'
license=('custom:neovim')
-depends=('jemalloc' 'libtermkey' 'libuv' 'libvterm' 'luajit' 'msgpack-c' 'unibilium')
-makedepends=('cmake' 'git' 'gperf' 'lua51-lpeg' 'lua51-mpack')
-optdepends=('python2-neovim: for Python 2 plugin support (see :help provider-python)'
- 'python-neovim: for Python 3 plugin support (see :help provider-python)'
- 'ruby-neovim: for Ruby plugin support (see :help provider-ruby)'
- 'xclip: for clipboard support (or xsel) (see :help provider-clipboard)'
- 'xsel: for clipboard support (or xclip) (see :help provider-clipboard)')
+depends=('libtermkey' 'libuv' 'libvterm' 'luajit' 'msgpack-c' 'unibilium')
+makedepends=('cmake' 'git' 'gperf' 'lua51-lpeg' 'lua51-mpack' 'ninja')
+optdepends=('python2-neovim: for Python 2 plugin support (see :help python)'
+ 'python-neovim: for Python 3 plugin support (see :help python)'
+ 'xclip: for clipboard support (or xsel) (see :help clipboard)'
+ 'xsel: for clipboard support (or xclip) (see :help clipboard)')
provides=("$_pkgname")
conflicts=("$_pkgname")
source=("git+https://github.com/$_pkgname/$_pkgname.git")
@@ -26,25 +25,29 @@ pkgver() {
}
build() {
- mkdir -p "$_pkgname/build"
- cd "$_pkgname/build"
- cmake -G 'Unix Makefiles' \
+ cd "$srcdir"
+ cmake -Hneovim -Bbuild -GNinja \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DENABLE_JEMALLOC=ON \
- ..
- make
+ -DENABLE_LIBINTL=OFF
+ cmake --build build
}
check() {
- cd "$_pkgname/build"
+ cd "$srcdir/build"
./bin/nvim --version
./bin/nvim --headless -u NONE -i NONE -c ':quit'
}
package() {
- cd "$_pkgname/build"
- make DESTDIR="$pkgdir" install
- install -Dm644 ../LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+ cd "$srcdir/build"
+ DESTDIR="$pkgdir" cmake --build . --target install
+ cd "$srcdir/$_pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+ #rm -rf "$pkgdir/usr/share/applications/"
+ #rm -rf "$pkgdir/usr/share/pixmaps/"
+ #rm -rf "$pkgdir/usr/share/nvim/runtime/"{autoload/tutor.vim,doc/pi_tutor.txt,plugin/tutor.vim,syntax/tutor.vim,tutor/}
+ #rm -rf "$pkgdir/usr/share/nvim/runtime/"{doc/pi_matchit.txt,macros/matchit.vim,plugin/matchit.vim}
+ #rm "$pkgdir/usr/share/nvim/runtime/plugin/"{gzip,matchparen,netrwPlugin,rplugin,spellfile,tarPlugin,tohtml,zipPlugin}.vim
ln -s nvim "$pkgdir/usr/bin/vim"
}
diff --git a/vifm/PKGBUILD b/vifm/PKGBUILD
index 5219a71..9ea409b 100644
--- a/vifm/PKGBUILD
+++ b/vifm/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=vifm
pkgname=$_pkgname-jxir
-pkgver=0.10.r37.gc8d220ad3
+pkgver=0.10.r78.g91350c247
pkgrel=1
pkgdesc='A file manager with curses interface, which provides Vi[m]-like environment'
arch=('x86_64')